aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-09-22 12:06:25 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-06 21:28:49 +0200
commit794d4b66523f88ba7b420d973c8418c40d371a17 (patch)
tree1acadf1c78269af6221ca79e7e1b78f68e16137c /target/linux/ramips/image/rt3883.mk
parent3b874c2c819f7ca87668e53f2b366a70d27eea61 (diff)
downloadupstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.gz
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.bz2
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.zip
treewide: remove kmod-usb-core from DEVICE_PACKAGES
This removes _all_ occurrences of kmod-usb-core from DEVICE_PACKAGES and similar variables. This package is pulled as dependency by one of the following packages in any case: - kmod-usb-chipidea - kmod-usb-dwc2 - kmod-usb-ledtrig-usbport - kmod-usb-ohci - kmod-usb2 - kmod-usb2-pci - kmod-usb3 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [remove kmod-usb-core from EnGenius ESR600] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index de888a31b0..b0243bfe81 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -12,7 +12,7 @@ define Device/asus_rt-n56u
IMAGE/sysupgrade.bin += | mkrtn56uimg -s
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N56U
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
SUPPORTED_DEVICES += rt-n56u
endef
TARGET_DEVICES += asus_rt-n56u
@@ -23,7 +23,7 @@ define Device/belkin_f9k1109v1
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F9K1109
DEVICE_VARIANT := Version 1.0
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
IMAGE_SIZE := 7808k
KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
# Stock firmware checks for this uImage image name during upload.
@@ -40,7 +40,7 @@ define Device/dlink_dir-645
SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-645
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
SUPPORTED_DEVICES += dir-645
endef
TARGET_DEVICES += dlink_dir-645
@@ -75,7 +75,7 @@ define Device/omnima_hpm
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := HPM
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
SUPPORTED_DEVICES += hpm
endef
TARGET_DEVICES += omnima_hpm
@@ -89,7 +89,7 @@ define Device/samsung_cy-swr1100
SEAMA_SIGNATURE := wrgnd10_samsung_ss815
DEVICE_VENDOR := Samsung
DEVICE_MODEL := CY-SWR1100
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
SUPPORTED_DEVICES += cy-swr1100
endef
TARGET_DEVICES += samsung_cy-swr1100
@@ -103,7 +103,7 @@ define Device/sitecom_wlr-6000
senao-header -r 0x0202 -p 0x41 -t 2
DEVICE_VENDOR := Sitecom
DEVICE_MODEL := WLR-6000
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 swconfig
SUPPORTED_DEVICES += wlr-6000
endef
TARGET_DEVICES += sitecom_wlr-6000