aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt3883.mk
diff options
context:
space:
mode:
authorOliver Fleischmann <ogf@bnv-bamberg.de>2017-07-20 21:02:33 +0200
committerMathias Kresin <dev@kresin.me>2017-07-27 09:13:27 +0200
commita92c64e8ae38f6a221823610c4a2f454c813c484 (patch)
tree6b92f5d5c9647678520236e11cdcda5e789687db /target/linux/ramips/image/rt3883.mk
parenta3995a678551c699c9702ed28003c2ba868d2db1 (diff)
downloadupstream-a92c64e8ae38f6a221823610c4a2f454c813c484.tar.gz
upstream-a92c64e8ae38f6a221823610c4a2f454c813c484.tar.bz2
upstream-a92c64e8ae38f6a221823610c4a2f454c813c484.zip
ramips: add support for Loewe WMDR-143N
The WMDR-143N is a small module originally used as a Wifi client in some Loewe smart TV sets. It is sold cheaply at german surplus shops. The module contains a RT3662 SOC. Specifications: - 500 MHz CPU Clock - 1x 10/100Mbps Ethernet (pin header) - 32 MB of RAM - 8 MB of FLASH - 2T3R 2.4/5 GHz (SOC internal) - 3 Antennas on PCB - UART pads on PCB (J3: 1 = +3.3V, 2 = RX, 3 = TX, 4 = GND), TX and RX are 3,3V only! The square hole is pin 1 - Power supply pads on PCB (J6: 1 and 2 = +5V, 3 and 4 = GND) The square hole is pin 1 The original firmware has two identical kernel/rootfs images and two "Factory" calibration data blocks in flash. The LEDE image leaves only the first "Factory" block in place and uses both "Kernel" blocks and the redundant "Factory" block together to gain enough space for the jffs2 partition. Flash instructions: You need UART and Ethernet connections to flash the board. Use the LEDE "sysupgrade.bin" image with tftp. Apply power to the board and in the first 5 seconds, hit 2 to select TFTP upload. The bootloader asks for board- and server IP addresses and filename. Alternate method: With the vendor firmware running, assign an IP address to the ethernet port, tftp the firmware image to /tmp and write to mtd4 ("KernelA"). Signed-off-by: Oliver Fleischmann <ogf@bnv-bamberg.de> [remove pinctrl node from dts, no pin is used as GPIO] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt3883.mk')
-rw-r--r--target/linux/ramips/image/rt3883.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 2cd60f3858..f90fc6154f 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -114,3 +114,11 @@ define Device/wlr-6000
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
endef
TARGET_DEVICES += wlr-6000
+
+
+define Device/wmdr-143n
+ DTS := WMDR-143N
+ BLOCKSIZE := 64k
+ DEVICE_TITLE := Loewe WMDR-143N
+endef
+TARGET_DEVICES += wmdr-143n