aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:15:57 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:15:57 +0100
commit58e71e322bc0e0edd08157075e9022c15ae33ec5 (patch)
tree4d8f529a68db84b6c2ed19991e3eabc994cadab4 /target/linux/ramips/image/rt305x.mk
parent95030ac0b673165772daf27128359eaaf536d457 (diff)
downloadupstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.tar.gz
upstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.tar.bz2
upstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.zip
ramips: rename MTK_SOC to SOC
This replaces MTK_SOC by the newly introduced common SOC device variable. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk210
1 files changed, 105 insertions, 105 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 0550c7ffa9..f63891ac7c 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -22,7 +22,7 @@ define Build/hilink-header
endef
define Device/7links_px-4885-4m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
DEVICE_VENDOR := 7Links
DEVICE_MODEL := PX-4885
@@ -34,7 +34,7 @@ endef
TARGET_DEVICES += 7links_px-4885-4m
define Device/7links_px-4885-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := 7Links
DEVICE_MODEL := PX-4885
@@ -46,7 +46,7 @@ endef
TARGET_DEVICES += 7links_px-4885-8m
define Device/8devices_carambola
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 7872k
DEVICE_VENDOR := 8devices
DEVICE_MODEL := Carambola
@@ -56,7 +56,7 @@ endef
TARGET_DEVICES += 8devices_carambola
define Device/accton_wr6202
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Accton
DEVICE_MODEL := WR6202
@@ -65,7 +65,7 @@ endef
TARGET_DEVICES += accton_wr6202
define Device/airlive_air3gii
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := AirLive
@@ -75,7 +75,7 @@ endef
TARGET_DEVICES += airlive_air3gii
define Device/alfa-network_w502u
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := ALFA
DEVICE_MODEL := Networks W502U
@@ -84,7 +84,7 @@ endef
TARGET_DEVICES += alfa-network_w502u
define Device/allnet_all0256n-4m
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL0256N
@@ -95,7 +95,7 @@ endef
TARGET_DEVICES += allnet_all0256n-4m
define Device/allnet_all0256n-8m
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL0256N
@@ -106,7 +106,7 @@ endef
TARGET_DEVICES += allnet_all0256n-8m
define Device/allnet_all5002
- MTK_SOC := rt3352
+ SOC := rt3352
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL5002
@@ -117,7 +117,7 @@ endef
TARGET_DEVICES += allnet_all5002
define Device/allnet_all5003
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL5003
@@ -128,7 +128,7 @@ endef
TARGET_DEVICES += allnet_all5003
define Device/alphanetworks_asl26555-16m
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 15872k
DEVICE_VENDOR := Alpha
DEVICE_MODEL := ASL26555
@@ -139,7 +139,7 @@ endef
TARGET_DEVICES += alphanetworks_asl26555-16m
define Device/alphanetworks_asl26555-8m
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 7744k
DEVICE_VENDOR := Alpha
DEVICE_MODEL := ASL26555
@@ -149,7 +149,7 @@ endef
TARGET_DEVICES += alphanetworks_asl26555-8m
define Device/arcwireless_freestation5
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 7872k
DEVICE_VENDOR := ARC Wireless
DEVICE_MODEL := FreeStation
@@ -160,7 +160,7 @@ endef
TARGET_DEVICES += arcwireless_freestation5
define Device/argus_atp-52b
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7808k
DEVICE_VENDOR := Argus
DEVICE_MODEL := ATP-52B
@@ -169,7 +169,7 @@ endef
TARGET_DEVICES += argus_atp-52b
define Device/asiarf_awapn2403
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := AsiaRF
@@ -179,7 +179,7 @@ endef
TARGET_DEVICES += asiarf_awapn2403
define Device/asiarf_awm002-evb-4m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AWM002-EVB
@@ -190,7 +190,7 @@ endef
TARGET_DEVICES += asiarf_awm002-evb-4m
define Device/asiarf_awm002-evb-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AWM002-EVB/AWM003-EVB
@@ -201,7 +201,7 @@ endef
TARGET_DEVICES += asiarf_awm002-evb-8m
define Device/asus_rt-g32-b1
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
@@ -212,7 +212,7 @@ endef
TARGET_DEVICES += asus_rt-g32-b1
define Device/asus_rt-n10-plus
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
@@ -222,7 +222,7 @@ endef
TARGET_DEVICES += asus_rt-n10-plus
define Device/asus_rt-n13u
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N13U
@@ -232,7 +232,7 @@ endef
TARGET_DEVICES += asus_rt-n13u
define Device/asus_wl-330n
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
@@ -242,7 +242,7 @@ endef
TARGET_DEVICES += asus_wl-330n
define Device/asus_wl-330n3g
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
@@ -253,7 +253,7 @@ endef
TARGET_DEVICES += asus_wl-330n3g
define Device/aximcom_mr-102n
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7744k
DEVICE_VENDOR := AXIMCom
DEVICE_MODEL := MR-102N
@@ -262,7 +262,7 @@ endef
TARGET_DEVICES += aximcom_mr-102n
define Device/aztech_hw550-3g
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Aztech
DEVICE_MODEL := HW550-3G
@@ -274,7 +274,7 @@ endef
TARGET_DEVICES += aztech_hw550-3g
define Device/belkin_f5d8235-v2
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7744k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F5D8235
@@ -285,7 +285,7 @@ endef
TARGET_DEVICES += belkin_f5d8235-v2
define Device/belkin_f7c027
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7616k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F7C027
@@ -295,7 +295,7 @@ endef
TARGET_DEVICES += belkin_f7c027
define Device/buffalo_whr-g300n
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3712k
DEVICE_VENDOR := Buffalo
@@ -308,7 +308,7 @@ endef
TARGET_DEVICES += buffalo_whr-g300n
define Device/dlink_dap-1350
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGES += factory.bin factory-NA.bin
IMAGE_SIZE := 7488k
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -322,7 +322,7 @@ endef
TARGET_DEVICES += dlink_dap-1350
define Device/dlink_dcs-930
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DCS-930
@@ -333,7 +333,7 @@ endef
TARGET_DEVICES += dlink_dcs-930
define Device/dlink_dcs-930l-b1
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DCS-930L
@@ -345,7 +345,7 @@ endef
TARGET_DEVICES += dlink_dcs-930l-b1
define Device/dlink_dir-300-b1
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -358,7 +358,7 @@ endef
TARGET_DEVICES += dlink_dir-300-b1
define Device/dlink_dir-300-b7
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 4k
IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
@@ -369,7 +369,7 @@ endef
TARGET_DEVICES += dlink_dir-300-b7
define Device/dlink_dir-320-b1
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-320
@@ -379,7 +379,7 @@ endef
TARGET_DEVICES += dlink_dir-320-b1
define Device/dlink_dir-600-b1
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -393,7 +393,7 @@ TARGET_DEVICES += dlink_dir-600-b1
define Device/dlink_dir-610-a1
$(Device/seama)
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 4k
SEAMA_SIGNATURE := wrgn59_dlob.hans_dir610
KERNEL := $(KERNEL_DTB)
@@ -407,7 +407,7 @@ endef
TARGET_DEVICES += dlink_dir-610-a1
define Device/dlink_dir-615-d
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -420,7 +420,7 @@ endef
TARGET_DEVICES += dlink_dir-615-d
define Device/dlink_dir-615-h1
- MTK_SOC := rt3352
+ SOC := rt3352
BLOCKSIZE := 4k
IMAGES += factory.bin
IMAGE_SIZE := 3776k
@@ -433,7 +433,7 @@ endef
TARGET_DEVICES += dlink_dir-615-h1
define Device/dlink_dir-620-a1
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-620
@@ -443,7 +443,7 @@ endef
TARGET_DEVICES += dlink_dir-620-a1
define Device/dlink_dir-620-d1
- MTK_SOC := rt3352
+ SOC := rt3352
IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-620
@@ -453,7 +453,7 @@ endef
TARGET_DEVICES += dlink_dir-620-d1
define Device/dlink_dwr-512-b
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 8064k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DWR-512
@@ -472,7 +472,7 @@ endef
TARGET_DEVICES += dlink_dwr-512-b
define Device/easyacc_wizard-8800
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := EasyAcc
@@ -482,7 +482,7 @@ endef
TARGET_DEVICES += easyacc_wizard-8800
define Device/edimax_3g-6200n
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3648k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
edimax-header -s CSYS -m 3G62 -f 0x50000 -S 0x01100000 | pad-rootfs | \
@@ -494,7 +494,7 @@ endef
TARGET_DEVICES += edimax_3g-6200n
define Device/edimax_3g-6200nl
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3648k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
edimax-header -s CSYS -m 3G62 -f 0x50000 -S 0x01100000 | pad-rootfs | \
@@ -506,7 +506,7 @@ endef
TARGET_DEVICES += edimax_3g-6200nl
define Device/engenius_esr-9753
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := EnGenius
@@ -516,7 +516,7 @@ endef
TARGET_DEVICES += engenius_esr-9753
define Device/fon_fonera-20n
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | \
@@ -529,7 +529,7 @@ endef
TARGET_DEVICES += fon_fonera-20n
define Device/hame_mpr-a1
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
UIMAGE_NAME:= Linux Kernel Image
@@ -542,7 +542,7 @@ endef
TARGET_DEVICES += hame_mpr-a1
define Device/hame_mpr-a2
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := HAME
@@ -554,7 +554,7 @@ endef
TARGET_DEVICES += hame_mpr-a2
define Device/hauppauge_broadway
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7744k
UIMAGE_NAME:= Broadway Kernel Image
DEVICE_VENDOR := Hauppauge
@@ -565,7 +565,7 @@ endef
TARGET_DEVICES += hauppauge_broadway
define Device/hilink_hlk-rm04
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -577,7 +577,7 @@ endef
TARGET_DEVICES += hilink_hlk-rm04
define Device/hootoo_ht-tm02
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := HooToo
DEVICE_MODEL := HT-TM02
@@ -587,7 +587,7 @@ endef
TARGET_DEVICES += hootoo_ht-tm02
define Device/huawei_d105
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Huawei
@@ -597,7 +597,7 @@ endef
TARGET_DEVICES += huawei_d105
define Device/huawei_hg255d
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 15744k
DEVICE_VENDOR := HuaWei
DEVICE_MODEL := HG255D
@@ -606,7 +606,7 @@ endef
TARGET_DEVICES += huawei_hg255d
define Device/intenso_memory2move
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := Intenso
@@ -618,7 +618,7 @@ endef
TARGET_DEVICES += intenso_memory2move
define Device/jcg_jhr-n805r
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -630,7 +630,7 @@ endef
TARGET_DEVICES += jcg_jhr-n805r
define Device/jcg_jhr-n825r
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -642,7 +642,7 @@ endef
TARGET_DEVICES += jcg_jhr-n825r
define Device/jcg_jhr-n926r
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -654,7 +654,7 @@ endef
TARGET_DEVICES += jcg_jhr-n926r
define Device/mofinetwork_mofi3500-3gn
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := MoFi Network
DEVICE_MODEL := MOFI3500-3GN
@@ -663,7 +663,7 @@ endef
TARGET_DEVICES += mofinetwork_mofi3500-3gn
define Device/netcore_nw718
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3712k
UIMAGE_NAME:= ARA1B4NCRNW718;1
DEVICE_VENDOR := Netcore
@@ -673,7 +673,7 @@ endef
TARGET_DEVICES += netcore_nw718
define Device/netgear_wnce2001
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3392k
IMAGES += factory.bin factory-NA.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -687,7 +687,7 @@ endef
TARGET_DEVICES += netgear_wnce2001
define Device/nexaira_bc2
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := NexAira
DEVICE_MODEL := BC2
@@ -696,7 +696,7 @@ endef
TARGET_DEVICES += nexaira_bc2
define Device/nexx_wt1520-4m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -709,7 +709,7 @@ endef
TARGET_DEVICES += nexx_wt1520-4m
define Device/nexx_wt1520-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -722,7 +722,7 @@ endef
TARGET_DEVICES += nexx_wt1520-8m
define Device/nixcore_x1-16m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Nixcore
DEVICE_MODEL := X1
@@ -734,7 +734,7 @@ endef
TARGET_DEVICES += nixcore_x1-16m
define Device/nixcore_x1-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Nixcore
DEVICE_MODEL := X1
@@ -746,7 +746,7 @@ endef
TARGET_DEVICES += nixcore_x1-8m
define Device/olimex_rt5350f-olinuxino
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX
DEVICE_MODEL := RT5350F-OLinuXino
@@ -757,7 +757,7 @@ endef
TARGET_DEVICES += olimex_rt5350f-olinuxino
define Device/olimex_rt5350f-olinuxino-evb
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX
DEVICE_MODEL := RT5350F-OLinuXino-EVB
@@ -768,7 +768,7 @@ endef
TARGET_DEVICES += olimex_rt5350f-olinuxino-evb
define Device/omnima_miniembplug
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := MiniEMBPlug
@@ -777,7 +777,7 @@ endef
TARGET_DEVICES += omnima_miniembplug
define Device/omnima_miniembwifi
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := MiniEMBWiFi
@@ -786,7 +786,7 @@ endef
TARGET_DEVICES += omnima_miniembwifi
define Device/petatel_psr-680w
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Petatel
@@ -796,7 +796,7 @@ endef
TARGET_DEVICES += petatel_psr-680w
define Device/planex_mzk-dp150n
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Planex
@@ -807,7 +807,7 @@ endef
TARGET_DEVICES += planex_mzk-dp150n
define Device/planex_mzk-w300nh2
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3648k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | \
@@ -819,7 +819,7 @@ endef
TARGET_DEVICES += planex_mzk-w300nh2
define Device/planex_mzk-wdpr
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 6656k
DEVICE_VENDOR := Planex
DEVICE_MODEL := MZK-WDPR
@@ -828,7 +828,7 @@ endef
TARGET_DEVICES += planex_mzk-wdpr
define Device/poray_ip2202
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Poray
DEVICE_MODEL := IP2202
@@ -837,7 +837,7 @@ endef
TARGET_DEVICES += poray_ip2202
define Device/poray_m3
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -850,7 +850,7 @@ endef
TARGET_DEVICES += poray_m3
define Device/poray_m4-4m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -864,7 +864,7 @@ endef
TARGET_DEVICES += poray_m4-4m
define Device/poray_m4-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -878,7 +878,7 @@ endef
TARGET_DEVICES += poray_m4-8m
define Device/poray_x5
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -891,7 +891,7 @@ endef
TARGET_DEVICES += poray_x5
define Device/poray_x8
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -904,7 +904,7 @@ endef
TARGET_DEVICES += poray_x8
define Device/prolink_pwh2004
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Prolink
DEVICE_MODEL := PWH2004
@@ -914,7 +914,7 @@ endef
TARGET_DEVICES += prolink_pwh2004
define Device/ralink_v22rw-2x2
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
@@ -924,7 +924,7 @@ endef
TARGET_DEVICES += ralink_v22rw-2x2
define Device/sitecom_wl-351
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Sitecom
@@ -935,7 +935,7 @@ endef
TARGET_DEVICES += sitecom_wl-351
define Device/skyline_sl-r7205
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Skyline
@@ -945,7 +945,7 @@ endef
TARGET_DEVICES += skyline_sl-r7205
define Device/sparklan_wcr-150gn
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Sparklan
@@ -955,7 +955,7 @@ endef
TARGET_DEVICES += sparklan_wcr-150gn
define Device/teltonika_rut5xx
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Teltonika
DEVICE_MODEL := RUT5XX
@@ -965,7 +965,7 @@ endef
TARGET_DEVICES += teltonika_rut5xx
define Device/tenda_3g150b
- MTK_SOC := rt5350
+ SOC := rt5350
BLOCKSIZE := 4k
IMAGE_SIZE := 3776k
UIMAGE_NAME:= Linux Kernel Image
@@ -977,7 +977,7 @@ endef
TARGET_DEVICES += tenda_3g150b
define Device/tenda_3g300m
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3776k
UIMAGE_NAME := 3G150M_SPI Kernel Image
DEVICE_VENDOR := Tenda
@@ -988,7 +988,7 @@ endef
TARGET_DEVICES += tenda_3g300m
define Device/tenda_w150m
- MTK_SOC := rt3050
+ SOC := rt3050
IMAGE_SIZE := 3776k
UIMAGE_NAME:= W150M Kernel Image
DEVICE_VENDOR := Tenda
@@ -998,7 +998,7 @@ endef
TARGET_DEVICES += tenda_w150m
define Device/tenda_w306r-v2
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3776k
UIMAGE_NAME:= linkn Kernel Image
DEVICE_VENDOR := Tenda
@@ -1009,7 +1009,7 @@ endef
TARGET_DEVICES += tenda_w306r-v2
define Device/trendnet_tew-638apb-v2
- MTK_SOC := rt3050
+ SOC := rt3050
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
@@ -1022,7 +1022,7 @@ endef
TARGET_DEVICES += trendnet_tew-638apb-v2
define Device/trendnet_tew-714tru
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := TRENDnet
DEVICE_MODEL := TEW-714TRU
@@ -1031,7 +1031,7 @@ endef
TARGET_DEVICES += trendnet_tew-714tru
define Device/unbranded_a5-v11
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -1044,7 +1044,7 @@ endef
TARGET_DEVICES += unbranded_a5-v11
define Device/unbranded_wr512-3gn-4m
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := WR512-3GN
@@ -1054,7 +1054,7 @@ endef
TARGET_DEVICES += unbranded_wr512-3gn-4m
define Device/unbranded_wr512-3gn-8m
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := WR512-3GN
@@ -1064,7 +1064,7 @@ endef
TARGET_DEVICES += unbranded_wr512-3gn-8m
define Device/unbranded_xdx-rn502j
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := XDX
@@ -1074,7 +1074,7 @@ endef
TARGET_DEVICES += unbranded_xdx-rn502j
define Device/upvel_ur-326n4g
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := UPVEL
@@ -1085,7 +1085,7 @@ endef
TARGET_DEVICES += upvel_ur-326n4g
define Device/upvel_ur-336un
- MTK_SOC := rt3052
+ SOC := rt3052
IMAGE_SIZE := 7872k
DEVICE_VENDOR := UPVEL
DEVICE_MODEL := UR-336UN
@@ -1095,7 +1095,7 @@ endef
TARGET_DEVICES += upvel_ur-336un
define Device/vocore_vocore-16m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 16064k
DEVICE_VENDOR := VoCore
DEVICE_MODEL := VoCore
@@ -1107,7 +1107,7 @@ endef
TARGET_DEVICES += vocore_vocore-16m
define Device/vocore_vocore-8m
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := VoCore
DEVICE_MODEL := VoCore
@@ -1119,7 +1119,7 @@ endef
TARGET_DEVICES += vocore_vocore-8m
define Device/wansview_ncs601w
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Wansview
DEVICE_MODEL := NCS601W
@@ -1129,7 +1129,7 @@ endef
TARGET_DEVICES += wansview_ncs601w
define Device/wiznet_wizfi630a
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 16064k
DEVICE_VENDOR := WIZnet
DEVICE_MODEL := WizFi630A
@@ -1138,7 +1138,7 @@ endef
TARGET_DEVICES += wiznet_wizfi630a
define Device/zorlik_zl5900v2
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Zorlik
DEVICE_MODEL := ZL5900V2
@@ -1147,7 +1147,7 @@ endef
TARGET_DEVICES += zorlik_zl5900v2
define Device/zyxel_keenetic
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
@@ -1158,7 +1158,7 @@ endef
TARGET_DEVICES += zyxel_keenetic
define Device/zyxel_keenetic-start
- MTK_SOC := rt5350
+ SOC := rt5350
IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := Keenetic Start
@@ -1166,7 +1166,7 @@ endef
TARGET_DEVICES += zyxel_keenetic-start
define Device/zyxel_nbg-419n
- MTK_SOC := rt3052
+ SOC := rt3052
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
@@ -1176,7 +1176,7 @@ endef
TARGET_DEVICES += zyxel_nbg-419n
define Device/zyxel_nbg-419n-v2
- MTK_SOC := rt3352
+ SOC := rt3352
IMAGE_SIZE := 7872k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NBG-419N