aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 19:25:00 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:12 +0100
commit7c1332d95fbaea2e0a5029947a2b8d3d43c171b4 (patch)
treee8c69566ba38214068e6906ceec07c33c7657298 /target/linux/ramips/image/rt305x.mk
parentd3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47 (diff)
downloadupstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.gz
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.bz2
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.zip
ramips: consolidate seama image build code
Create a common template which has the required image build code defined. Add some new variables to pass individual parts to the seama recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk13
1 files changed, 2 insertions, 11 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 5f514290dc..163726e1e1 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -262,21 +262,12 @@ endef
TARGET_DEVICES += dir-600-b1
define Device/dir-610-a1
+ $(Device/seama)
DTS := DIR-610-A1
BLOCKSIZE := 4k
- IMAGES += factory.bin
+ SEAMA_SIGNATURE := wrgn59_dlob.hans_dir610
KERNEL := $(KERNEL_DTB)
IMAGE_SIZE := $(ralink_default_fw_size_4M)
- IMAGE/sysupgrade.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
- append-rootfs | pad-rootfs -x 64 | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- seama-seal -m "signature=wrgn59_dlob.hans_dir610" | \
- check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := D-Link DIR-610 A1
DEVICE_PACKAGES := kmod-ledtrig-netdev kmod-ledtrig-timer
endef