aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2018-02-12 03:42:47 +0900
committerJohn Crispin <john@phrozen.org>2018-02-13 10:01:53 +0100
commit192b5a7710a47c235295101776a61996865968ca (patch)
treedf86cca979a61a7fc946ebf70860b2eae300e1e4 /target/linux/ramips/image/rt305x.mk
parent5555545494c876adedf4f0038db49c1d85527e78 (diff)
downloadupstream-192b5a7710a47c235295101776a61996865968ca.tar.gz
upstream-192b5a7710a47c235295101776a61996865968ca.tar.bz2
upstream-192b5a7710a47c235295101776a61996865968ca.zip
ramips: use new image build code for WHR-G300N
The tftp.bin image for Buffalo WHR-G300N was not built, so I was fixed it after rewriting to new image build code. And the code for factory-EU.bin was broken, so I deleted it. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 4e82eb48a9..dbf15bc7d7 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -1,6 +1,16 @@
#
# RT305X Profiles
#
+define Build/buffalo-tftp-header
+ ( \
+ echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
+ dd bs=512 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.tmp && \
+ $(STAGING_DIR_HOST)/bin/buffalo-tftp -i $@.tmp -o $@.new
+ mv $@.new $@
+endef
+
define Build/dap-header
$(STAGING_DIR_HOST)/bin/mkdapimg $(1) -i $@ -o $@.new
mv $@.new $@
@@ -745,6 +755,17 @@ define Device/wcr-150gn
endef
TARGET_DEVICES += wcr-150gn
+define Device/whr-g300n
+ DTS := WHR-G300N
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 3801088
+ DEVICE_TITLE := Buffalo WHR-G300N
+ IMAGES += tftp.bin
+ IMAGE/tftp.bin := $$(sysupgrade_bin) | \
+ check-size $$$$(IMAGE_SIZE) | buffalo-tftp-header
+endef
+TARGET_DEVICES += whr-g300n
+
define Device/wizard8800
DTS := WIZARD8800
UIMAGE_NAME:= Linux Kernel Image