aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-22 18:09:57 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:30 +0200
commit9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89 (patch)
tree5c4a1bf8f193064092d6559efc27c3c279c2f355 /target/linux/ramips/image/rt305x.mk
parent363197311b342a59b3c67e4bd2dfea3b3030b456 (diff)
downloadupstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.tar.gz
upstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.tar.bz2
upstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.zip
ramips: remove ralink_default_fw_size_xxx variables
There are frequent examples of the ralink_default_fw_size_xxx variables being used to "roughly" set flash size without caring about the actual size of the firmware partition. To discourage this behavior, this patch removes the variables and just sets IMAGE_SIZE by its numeric value for each target. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk164
1 files changed, 82 insertions, 82 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 52fa84c3eb..c57353f232 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -23,7 +23,7 @@ endef
define Device/7links_px-4885-4m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := 7Links
DEVICE_MODEL := PX-4885
DEVICE_VARIANT := 4M
@@ -35,7 +35,7 @@ TARGET_DEVICES += 7links_px-4885-4m
define Device/7links_px-4885-8m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := 7Links
DEVICE_MODEL := PX-4885
DEVICE_VARIANT := 8M
@@ -47,7 +47,7 @@ TARGET_DEVICES += 7links_px-4885-8m
define Device/8devices_carambola
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := 8devices
DEVICE_MODEL := Carambola
DEVICE_PACKAGES :=
@@ -57,7 +57,7 @@ TARGET_DEVICES += 8devices_carambola
define Device/accton_wr6202
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Accton
DEVICE_MODEL := WR6202
SUPPORTED_DEVICES += wr6202
@@ -67,7 +67,7 @@ TARGET_DEVICES += accton_wr6202
define Device/airlive_air3gii
MTK_SOC := rt5350
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := AirLive
DEVICE_MODEL := Air3GII
SUPPORTED_DEVICES += air3gii
@@ -76,7 +76,7 @@ TARGET_DEVICES += airlive_air3gii
define Device/alfa-network_w502u
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := ALFA
DEVICE_MODEL := Networks W502U
SUPPORTED_DEVICES += w502u
@@ -85,7 +85,7 @@ TARGET_DEVICES += alfa-network_w502u
define Device/allnet_all0256n-4m
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL0256N
DEVICE_VARIANT := 4M
@@ -96,7 +96,7 @@ TARGET_DEVICES += allnet_all0256n-4m
define Device/allnet_all0256n-8m
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Allnet
DEVICE_MODEL := ALL0256N
DEVICE_VARIANT := 8M
@@ -150,7 +150,7 @@ TARGET_DEVICES += alphanetworks_asl26555-8m
define Device/arcwireless_freestation5
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := ARC Wireless
DEVICE_MODEL := FreeStation
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-rt2500-usb kmod-rt2800-usb kmod-rt2x00-usb
@@ -170,7 +170,7 @@ TARGET_DEVICES += argus_atp-52b
define Device/asiarf_awapn2403
MTK_SOC := rt3052
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AWAPN2403
SUPPORTED_DEVICES += awapn2403
@@ -179,7 +179,7 @@ TARGET_DEVICES += asiarf_awapn2403
define Device/asiarf_awm002-evb-4m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AWM002-EVB
DEVICE_VARIANT := 4M
@@ -191,7 +191,7 @@ TARGET_DEVICES += asiarf_awm002-evb-4m
define Device/asiarf_awm002-evb-8m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AWM002-EVB/AWM003-EVB
DEVICE_VARIANT := 8M
@@ -204,7 +204,7 @@ TARGET_DEVICES += asiarf_awm002-evb-8m
define Device/asus_rt-g32-b1
MTK_SOC := rt3050
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-G32
DEVICE_VARIANT := B1
@@ -215,7 +215,7 @@ TARGET_DEVICES += asus_rt-g32-b1
define Device/asus_rt-n10-plus
MTK_SOC := rt3050
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N10+
SUPPORTED_DEVICES += rt-n10-plus
@@ -224,7 +224,7 @@ TARGET_DEVICES += asus_rt-n10-plus
define Device/asus_rt-n13u
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N13U
DEVICE_PACKAGES := kmod-leds-gpio kmod-rt2800-pci kmod-usb-dwc2
@@ -235,7 +235,7 @@ TARGET_DEVICES += asus_rt-n13u
define Device/asus_wl-330n
MTK_SOC := rt3050
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
DEVICE_MODEL := WL-330N
SUPPORTED_DEVICES += wl-330n
@@ -245,7 +245,7 @@ TARGET_DEVICES += asus_wl-330n
define Device/asus_wl-330n3g
MTK_SOC := rt3050
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
DEVICE_MODEL := WL-330N3G
DEVICE_PACKAGES :=
@@ -264,7 +264,7 @@ TARGET_DEVICES += aximcom_mr-102n
define Device/aztech_hw550-3g
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Aztech
DEVICE_MODEL := HW550-3G
DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport
@@ -322,7 +322,7 @@ TARGET_DEVICES += dlink_dap-1350
define Device/dlink_dcs-930
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DCS-930
DEVICE_PACKAGES := kmod-video-core kmod-video-uvc kmod-sound-core kmod-usb-audio kmod-usb-core kmod-usb-dwc2
@@ -332,7 +332,7 @@ TARGET_DEVICES += dlink_dcs-930
define Device/dlink_dcs-930l-b1
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DCS-930L
DEVICE_VARIANT := B1
@@ -343,7 +343,7 @@ TARGET_DEVICES += dlink_dcs-930l-b1
define Device/dlink_dir-300-b1
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | wrg-header wrgn23_dlwbr_dir300b
@@ -357,7 +357,7 @@ TARGET_DEVICES += dlink_dir-300-b1
define Device/dlink_dir-300-b7
MTK_SOC := rt5350
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-300
DEVICE_VARIANT := B7
@@ -367,7 +367,7 @@ TARGET_DEVICES += dlink_dir-300-b7
define Device/dlink_dir-320-b1
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-320
DEVICE_VARIANT := B1
@@ -377,7 +377,7 @@ TARGET_DEVICES += dlink_dir-320-b1
define Device/dlink_dir-600-b1
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | wrg-header wrgn23_dlwbr_dir600b
@@ -394,7 +394,7 @@ define Device/dlink_dir-610-a1
BLOCKSIZE := 4k
SEAMA_SIGNATURE := wrgn59_dlob.hans_dir610
KERNEL := $(KERNEL_DTB)
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-610
DEVICE_VARIANT := A1
@@ -405,7 +405,7 @@ TARGET_DEVICES += dlink_dir-610-a1
define Device/dlink_dir-615-d
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | wrg-header wrgn23_dlwbr_dir615d
@@ -420,7 +420,7 @@ define Device/dlink_dir-615-h1
MTK_SOC := rt3352
BLOCKSIZE := 4k
IMAGES += factory.bin
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGE/factory.bin := \
$$(sysupgrade_bin) | senao-header -r 0x218 -p 0x30 -t 3
DEVICE_VENDOR := D-Link
@@ -432,7 +432,7 @@ TARGET_DEVICES += dlink_dir-615-h1
define Device/dlink_dir-620-a1
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-620
DEVICE_VARIANT := A1
@@ -442,7 +442,7 @@ TARGET_DEVICES += dlink_dir-620-a1
define Device/dlink_dir-620-d1
MTK_SOC := rt3352
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DIR-620
DEVICE_VARIANT := D1
@@ -472,7 +472,7 @@ TARGET_DEVICES += dlink_dwr-512-b
define Device/easyacc_wizard-8800
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := EasyAcc
DEVICE_MODEL := WIZARD 8800
@@ -507,7 +507,7 @@ TARGET_DEVICES += edimax_3g-6200nl
define Device/engenius_esr-9753
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := EnGenius
DEVICE_MODEL := ESR-9753
SUPPORTED_DEVICES += esr-9753
@@ -516,7 +516,7 @@ TARGET_DEVICES += engenius_esr-9753
define Device/fon_fonera-20n
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | \
edimax-header -s RSDK -m NL1T -f 0x50000 -S 0xc0000
@@ -530,7 +530,7 @@ TARGET_DEVICES += fon_fonera-20n
define Device/hame_mpr-a1
MTK_SOC := rt5350
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := HAME
DEVICE_MODEL := MPR
@@ -542,7 +542,7 @@ TARGET_DEVICES += hame_mpr-a1
define Device/hame_mpr-a2
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := HAME
DEVICE_MODEL := MPR
@@ -565,7 +565,7 @@ TARGET_DEVICES += hauppauge_broadway
define Device/hilink_hlk-rm04
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | hilink-header
@@ -577,7 +577,7 @@ TARGET_DEVICES += hilink_hlk-rm04
define Device/hootoo_ht-tm02
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := HooToo
DEVICE_MODEL := HT-TM02
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
@@ -588,7 +588,7 @@ TARGET_DEVICES += hootoo_ht-tm02
define Device/huawei_d105
MTK_SOC := rt3050
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Huawei
DEVICE_MODEL := D105
SUPPORTED_DEVICES += d105
@@ -606,7 +606,7 @@ TARGET_DEVICES += huawei_hg255d
define Device/intenso_memory2move
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := Intenso
DEVICE_MODEL := Memory 2 Move
@@ -619,7 +619,7 @@ TARGET_DEVICES += intenso_memory2move
define Device/jcg_jhr-n805r
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | jcg-header 29.24
@@ -631,7 +631,7 @@ TARGET_DEVICES += jcg_jhr-n805r
define Device/jcg_jhr-n825r
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | jcg-header 23.24
@@ -643,7 +643,7 @@ TARGET_DEVICES += jcg_jhr-n825r
define Device/jcg_jhr-n926r
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | jcg-header 25.24
@@ -655,7 +655,7 @@ TARGET_DEVICES += jcg_jhr-n926r
define Device/mofinetwork_mofi3500-3gn
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := MoFi Network
DEVICE_MODEL := MOFI3500-3GN
SUPPORTED_DEVICES += mofi3500-3gn
@@ -688,7 +688,7 @@ TARGET_DEVICES += netgear_wnce2001
define Device/nexaira_bc2
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := NexAira
DEVICE_MODEL := BC2
SUPPORTED_DEVICES += bc2
@@ -697,7 +697,7 @@ TARGET_DEVICES += nexaira_bc2
define Device/nexx_wt1520-4m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B WT1520 -F 4M
@@ -710,7 +710,7 @@ TARGET_DEVICES += nexx_wt1520-4m
define Device/nexx_wt1520-8m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B WT1520 -F 8M
@@ -745,7 +745,7 @@ TARGET_DEVICES += nixcore_x1-8m
define Device/olimex_rt5350f-olinuxino
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX
DEVICE_MODEL := RT5350F-OLinuXino
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
@@ -757,7 +757,7 @@ TARGET_DEVICES += olimex_rt5350f-olinuxino
define Device/olimex_rt5350f-olinuxino-evb
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX
DEVICE_MODEL := RT5350F-OLinuXino-EVB
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
@@ -769,7 +769,7 @@ TARGET_DEVICES += olimex_rt5350f-olinuxino-evb
define Device/omnima_miniembplug
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := MiniEMBPlug
SUPPORTED_DEVICES += miniembplug
@@ -778,7 +778,7 @@ TARGET_DEVICES += omnima_miniembplug
define Device/omnima_miniembwifi
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Omnima
DEVICE_MODEL := MiniEMBWiFi
SUPPORTED_DEVICES += miniembwifi
@@ -788,7 +788,7 @@ TARGET_DEVICES += omnima_miniembwifi
define Device/petatel_psr-680w
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Petatel
DEVICE_MODEL := PSR-680W Wireless 3G Router
SUPPORTED_DEVICES += psr-680w
@@ -798,7 +798,7 @@ TARGET_DEVICES += petatel_psr-680w
define Device/planex_mzk-dp150n
MTK_SOC := rt5350
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Planex
DEVICE_MODEL := MZK-DP150N
DEVICE_PACKAGES := kmod-spi-dev
@@ -829,7 +829,7 @@ TARGET_DEVICES += planex_mzk-wdpr
define Device/poray_ip2202
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Poray
DEVICE_MODEL := IP2202
SUPPORTED_DEVICES += ip2202
@@ -838,7 +838,7 @@ TARGET_DEVICES += poray_ip2202
define Device/poray_m3
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B M3 -F 4M
@@ -852,7 +852,7 @@ TARGET_DEVICES += poray_m3
define Device/poray_m4-4m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B M4 -F 4M
@@ -867,7 +867,7 @@ TARGET_DEVICES += poray_m4-4m
define Device/poray_m4-8m
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B M4 -F 8M
@@ -881,7 +881,7 @@ TARGET_DEVICES += poray_m4-8m
define Device/poray_x5
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B X5 -F 8M
@@ -894,7 +894,7 @@ TARGET_DEVICES += poray_x5
define Device/poray_x8
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B X8 -F 8M
@@ -907,7 +907,7 @@ TARGET_DEVICES += poray_x8
define Device/prolink_pwh2004
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Prolink
DEVICE_MODEL := PWH2004
DEVICE_PACKAGES :=
@@ -918,7 +918,7 @@ TARGET_DEVICES += prolink_pwh2004
define Device/ralink_v22rw-2x2
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := AP-RT3052-V22RW-2X2
SUPPORTED_DEVICES += v22rw-2x2
@@ -928,7 +928,7 @@ TARGET_DEVICES += ralink_v22rw-2x2
define Device/sitecom_wl-351
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Sitecom
DEVICE_MODEL := WL-351 v1
DEVICE_PACKAGES := kmod-switch-rtl8366rb kmod-swconfig swconfig
@@ -939,7 +939,7 @@ TARGET_DEVICES += sitecom_wl-351
define Device/skyline_sl-r7205
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Skyline
DEVICE_MODEL := SL-R7205 Wireless 3G Router
SUPPORTED_DEVICES += sl-r7205
@@ -949,7 +949,7 @@ TARGET_DEVICES += skyline_sl-r7205
define Device/sparklan_wcr-150gn
MTK_SOC := rt3050
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Sparklan
DEVICE_MODEL := WCR-150GN
SUPPORTED_DEVICES += wcr-150gn
@@ -958,7 +958,7 @@ TARGET_DEVICES += sparklan_wcr-150gn
define Device/teltonika_rut5xx
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 16064k
DEVICE_VENDOR := Teltonika
DEVICE_MODEL := RUT5XX
DEVICE_PACKAGES := om-watchdog
@@ -969,7 +969,7 @@ TARGET_DEVICES += teltonika_rut5xx
define Device/tenda_3g150b
MTK_SOC := rt5350
BLOCKSIZE := 4k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
UIMAGE_NAME:= Linux Kernel Image
DEVICE_VENDOR := Tenda
DEVICE_MODEL := 3G150B
@@ -980,7 +980,7 @@ TARGET_DEVICES += tenda_3g150b
define Device/tenda_3g300m
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
UIMAGE_NAME := 3G150M_SPI Kernel Image
DEVICE_VENDOR := Tenda
DEVICE_MODEL := 3G300M
@@ -991,7 +991,7 @@ TARGET_DEVICES += tenda_3g300m
define Device/tenda_w150m
MTK_SOC := rt3050
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
UIMAGE_NAME:= W150M Kernel Image
DEVICE_VENDOR := Tenda
DEVICE_MODEL := W150M
@@ -1001,7 +1001,7 @@ TARGET_DEVICES += tenda_w150m
define Device/tenda_w306r-v2
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
UIMAGE_NAME:= linkn Kernel Image
DEVICE_VENDOR := Tenda
DEVICE_MODEL := W306R
@@ -1013,7 +1013,7 @@ TARGET_DEVICES += tenda_w306r-v2
define Device/trendnet_tew-638apb-v2
MTK_SOC := rt3050
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
append-metadata | check-size $$$$(IMAGE_SIZE)
DEVICE_VENDOR := TRENDnet
@@ -1025,7 +1025,7 @@ TARGET_DEVICES += trendnet_tew-638apb-v2
define Device/trendnet_tew-714tru
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := TRENDnet
DEVICE_MODEL := TEW-714TRU
SUPPORTED_DEVICES += tew-714tru
@@ -1034,7 +1034,7 @@ TARGET_DEVICES += trendnet_tew-714tru
define Device/unbranded_a5-v11
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
IMAGES += factory.bin
IMAGE/factory.bin := \
$$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | poray-header -B A5-V11 -F 4M
@@ -1047,7 +1047,7 @@ TARGET_DEVICES += unbranded_a5-v11
define Device/unbranded_wr512-3gn-4m
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := WR512-3GN
DEVICE_VARIANT := 4M
@@ -1057,7 +1057,7 @@ TARGET_DEVICES += unbranded_wr512-3gn-4m
define Device/unbranded_wr512-3gn-8m
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := WR512-3GN
DEVICE_VARIANT := 8M
@@ -1068,7 +1068,7 @@ TARGET_DEVICES += unbranded_wr512-3gn-8m
define Device/unbranded_xdx-rn502j
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := XDX
DEVICE_MODEL := RN502J
SUPPORTED_DEVICES += xdxrn502j
@@ -1078,7 +1078,7 @@ TARGET_DEVICES += unbranded_xdx-rn502j
define Device/upvel_ur-326n4g
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := UPVEL
DEVICE_MODEL := UR-326N4G
DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport
@@ -1088,7 +1088,7 @@ TARGET_DEVICES += upvel_ur-326n4g
define Device/upvel_ur-336un
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := UPVEL
DEVICE_MODEL := UR-336UN
DEVICE_PACKAGES := kmod-usb-core kmod-usb-dwc2 kmod-usb-ledtrig-usbport
@@ -1124,7 +1124,7 @@ TARGET_DEVICES += vocore_vocore-8m
define Device/wansview_ncs601w
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Wansview
DEVICE_MODEL := NCS601W
DEVICE_PACKAGES := kmod-video-core kmod-video-uvc \
@@ -1135,7 +1135,7 @@ TARGET_DEVICES += wansview_ncs601w
define Device/wiznet_wizfi630a
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 16064k
DEVICE_VENDOR := WIZnet
DEVICE_MODEL := WizFi630A
SUPPORTED_DEVICES += wizfi630a
@@ -1144,7 +1144,7 @@ TARGET_DEVICES += wiznet_wizfi630a
define Device/zorlik_zl5900v2
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Zorlik
DEVICE_MODEL := ZL5900V2
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-netdev
@@ -1154,7 +1154,7 @@ TARGET_DEVICES += zorlik_zl5900v2
define Device/zyxel_keenetic
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := Keenetic
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
@@ -1164,7 +1164,7 @@ TARGET_DEVICES += zyxel_keenetic
define Device/zyxel_keenetic-start
MTK_SOC := rt5350
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := Keenetic Start
endef
@@ -1173,7 +1173,7 @@ TARGET_DEVICES += zyxel_keenetic-start
define Device/zyxel_nbg-419n
MTK_SOC := rt3052
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NBG-419N
SUPPORTED_DEVICES += nbg-419n
@@ -1182,7 +1182,7 @@ TARGET_DEVICES += zyxel_nbg-419n
define Device/zyxel_nbg-419n-v2
MTK_SOC := rt3352
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := NBG-419N
DEVICE_VARIANT := v2