aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorPavlo Samko <bulldozerbsg@gmail.com>2017-06-09 14:02:56 +0300
committerMathias Kresin <dev@kresin.me>2017-06-17 15:38:19 +0200
commit82f9486142adff9c0d34393a63d3844d1da7ed03 (patch)
tree9aae8fe12741d32043d694935ae52062927f6a4e /target/linux/ramips/image/rt305x.mk
parent259fc1e77892ef8b7fb41c5bc118b55e31e0554b (diff)
downloadupstream-82f9486142adff9c0d34393a63d3844d1da7ed03.tar.gz
upstream-82f9486142adff9c0d34393a63d3844d1da7ed03.tar.bz2
upstream-82f9486142adff9c0d34393a63d3844d1da7ed03.zip
ramips: add support for TRENDnet TEW-638APB V2
This patch add support for the TRENDnet TEW-638APB V2. Specification: - SoC: Ralink SoC RT3052F - Flash: 4MB - RAM: 32MB - Ethernet: 1x LAN (100 Mbps) - Wireless: 2.4GHz b/g/n, 2x external antenna - Buttons: 1x Reset, 1x WPS - LEDs: Power (green), Ethernet (green), WPS (green and orange), Wireless (green) - UART: 1x UART on PCB (3.3V, GND, RX, TX) - 57600 8N1 Installation via vendor firmware: - upload sysupgrade.bin image via TFTP: - stop uboot into tftp-load into option "2" - upload sysupgrade.bin image Signed-off-by: Pavlo Samko <bulldozerbsg@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index dc09765c7c..628b84b2fd 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -651,6 +651,16 @@ define Device/sl-r7205
endef
TARGET_DEVICES += sl-r7205
+define Device/tew-638apb-v2
+ DTS := TEW-638APB-V2
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := TRENDnet TEW-638APB v2
+endef
+TARGET_DEVICES += tew-638apb-v2
+
define Device/tew-714tru
DTS := TEW-714TRU
DEVICE_TITLE := TRENDnet TEW-714TRU