aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:02 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:01 +0200
commit7392af752042337c99fd07dd7a7d75db5c6cd59b (patch)
treecf8929c4129420d40bec6bebcbea7b7491850139 /target/linux/ramips/image/rt305x.mk
parentb9cf1f60811730a54c918d1118725e88e29e0950 (diff)
downloadupstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.gz
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.bz2
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.zip
ramips: fix ralink_default_fw_size_16M
In ramips, there are the following predefined values for IMAGE_SIZE ralink_default_fw_size_4M 3866624 3776k 0x3B0000 ralink_default_fw_size_8M 8060928 7872k 0x7B0000 ralink_default_fw_size_16M 16121856 15744k 0xF60000 ralink_default_fw_size_32M 33226752 32448k 0x1FB0000 Out of those, the "16M" value is obviously odd, as it provides more room for the remaining partitions than the tree others. Of the devices in all subtargets, there are actually > 50 that have a firmware partition with 0xFB0000 size, while only 5 (!) have 0xF60000. From the former, many are set to ralink_default_fw_size_16M anyway, although it is wrong at the present point. Consequently, it makes sense to change ralink_default_fw_size_16M to 0xFB0000, and to update IMAGE_SIZE for the 5 devices with 0xF60000. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 2ba5e254e6..073f505d49 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -579,7 +579,7 @@ TARGET_DEVICES += huawei_d105
define Device/huawei_hg255d
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := HuaWei
DEVICE_MODEL := HG255D
SUPPORTED_DEVICES += hg255d