aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorVladimir Kot <vova28rus@gmail.com>2019-01-12 18:43:28 +0900
committerPetr Štetiar <ynezz@true.cz>2019-03-29 07:34:00 +0000
commit58becdb30d1048903ad704a227a52bdf695a0087 (patch)
treee1c7b3b16afbf340ea494efd8ab0199e1b4c797b /target/linux/ramips/image/rt305x.mk
parent7c4b85ee278576816b0f9d20e48fa696f8793fdf (diff)
downloadupstream-58becdb30d1048903ad704a227a52bdf695a0087.tar.gz
upstream-58becdb30d1048903ad704a227a52bdf695a0087.tar.bz2
upstream-58becdb30d1048903ad704a227a52bdf695a0087.zip
ramips: add support for ZyXEL Keenetic Start
Device specification: - SoC: RT5350F - CPU Frequency: 360 MHz - Flash Chip: Winbond 25Q32 (4096 KiB) - RAM: 32768 KiB - 5x 10/100 Mbps Ethernet (4x LAN, 1x WAN) - 1x external, non-detachable antenna - UART (J1) header on PCB (57800 8n1) - Wireless: SoC-intergated: 2.4GHz 802.11bgn - USB: None - 3x LED, 2x button Flash instruction: 1. Configure PC with static IP 192.168.1.2/24 and start TFTP server. 2. Rename "openwrt-ramips-rt305x-kn_st-squashfs-sysupgrade.bin" to "kstart_recovery.bin" and place it in TFTP server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed until power LED start blinking. 4. Router will download file from TFTP server, write it to flash and reboot. Signed-off-by: Vladimir Kot <vova28rus@gmail.com> [fixed git commit author and whitespace issues in DTS] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 163726e1e1..c67384f071 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -910,6 +910,13 @@ define Device/kn
endef
TARGET_DEVICES += kn
+define Device/zyxel_keenetic-start
+ DTS := kn_st
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := ZyXEL Keenetic Start
+endef
+TARGET_DEVICES += zyxel_keenetic-start
+
define Device/zorlik_zl5900v2
DTS := ZL5900V2
DEVICE_TITLE := Zorlik ZL5900V2