aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-29 23:40:12 +0100
committerMathias Kresin <dev@kresin.me>2018-12-12 11:01:59 +0100
commit262b885b834cecf7e7afbaca32d0a67c0b75aa44 (patch)
tree50b9bd0cc8c94b55e35cfc3f5d61acd4bb6cb2ed /target/linux/ramips/image/rt305x.mk
parent216397b8124dafafbd79afdf9f8e716b55775194 (diff)
downloadupstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.tar.gz
upstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.tar.bz2
upstream-262b885b834cecf7e7afbaca32d0a67c0b75aa44.zip
ramips: use new image build code for D-Link DCS-930 family
Drop the factory images and the firmware tool to create them. They don't work any more, since the factory image has an uImage header covering the whole kernel + rootfs. This way the uImage splitter will not be able to find the rootfs and the kernel will panic later on. The factory images were most likely added at a time the board had distinct partitions for kernel and rootfs. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index cc743c609d..5f514290dc 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -210,6 +210,22 @@ define Device/dap-1350
endef
TARGET_DEVICES += dap-1350
+define Device/dcs-930
+ DTS := DCS-930
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := D-Link DCS-930
+ DEVICE_PACKAGES := kmod-video-core kmod-video-uvc kmod-sound-core kmod-usb-audio kmod-usb-core kmod-usb-dwc2
+endef
+TARGET_DEVICES += dcs-930
+
+define Device/dcs-930l-b1
+ DTS := DCS-930L-B1
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := D-Link DCS-930L B1
+ DEVICE_PACKAGES := kmod-video-core kmod-video-uvc kmod-sound-core kmod-usb-audio kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+TARGET_DEVICES += dcs-930l-b1
+
define Device/dir-300-b1
DTS := DIR-300-B1
IMAGE_SIZE := $(ralink_default_fw_size_4M)