aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorAlexey Belyaev <spider@spider.vc>2017-04-28 00:02:05 +0600
committerMathias Kresin <dev@kresin.me>2017-05-10 08:45:12 +0200
commita7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6 (patch)
tree3db09931e0d2fc603c7b55d0a9963262c84163e4 /target/linux/ramips/image/rt305x.mk
parent54ea0f45c8b375ff29478c1f0d659d1548e89fc9 (diff)
downloadupstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.tar.gz
upstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.tar.bz2
upstream-a7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6.zip
ramips: add new device ZyXEL Keenetic as kn
This device exactly same as NBG-419N but with USB port and USB Led. Specification: - SoC: Ralink RT3052 (MIPS24Kc) @384MHz - RAM: 32 MiB - Flash: 8 MiB - WLAN: WiSoC 2T2R/300Mbps (2.4GHz) - LAN: 4x100M - WAN: 1x100M - USB: 1x2.0 Installation via serial console (57600 8N1) from TFTP server - rename the firmware to something shorter, for example "sysupgrade.bin" (max. 32 chars) - copy firmware TFTP server's directory - when you power on device, and see U-Boot log, immediatly push "2" once. - You will see this message: 2: System Load Linux Kernel then write to Flash via TFTP. Warning!! Erase Linux in Flash then burn new one. Are you sure? - Push "y", and enter: device IP, then TFTP server's IP, and then image firmware file name. The firmware will be downloaded within ~30 seconds and flashed to the device (It will take about 2 minutes). Signed-off-by: Alexey Belyaev <spider@spider.vc> [squash commits, compact commit message, fix compatible string, remove superfluous pinmuxes] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 69533ce9e7..62ced9b7de 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -850,3 +850,12 @@ define Device/xdxrn502j
DEVICE_TITLE := XDX RN502J
endef
TARGET_DEVICES += xdxrn502j
+
+define Device/kn
+ DTS := kn
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_TITLE := ZyXEL Keenetic
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += kn