aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2023-05-13 21:01:00 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-18 16:46:16 +0200
commit09a0efbe835428eaf436b17ae6709f0b22e48c5a (patch)
treed1fac02fd1a41d853f478385d912eb9ef439baea /target/linux/ramips/image/rt288x.mk
parentd343a15314195023c7c77884c86df4629f1bfa76 (diff)
downloadupstream-09a0efbe835428eaf436b17ae6709f0b22e48c5a.tar.gz
upstream-09a0efbe835428eaf436b17ae6709f0b22e48c5a.tar.bz2
upstream-09a0efbe835428eaf436b17ae6709f0b22e48c5a.zip
ramips: set default BLOCKSIZE to 64k for nor flash devices
In kernel 5.15, the default erase sector size of the nor flash has been switched from 4k to 64k. This may cause the configuration not be preserved across upgrades. To avoid this issue, change the default BLOCKSIZE to 64k. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 5e69e291d2..3d2d0c7ae0 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -12,11 +12,10 @@ define Build/gemtek-header
endef
define Device/airlink101_ar670w
- BLOCKSIZE := 64k
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR670W
IMAGE_SIZE := 3840k
- KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
+ KERNEL := $(KERNEL_DTB) | pad-to $$$$(BLOCKSIZE)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
wrg-header wrgn16a_airlink_ar670w
@@ -38,7 +37,6 @@ endef
TARGET_DEVICES += airlink101_ar725w
define Device/asus_rt-n15
- BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-N15
@@ -60,7 +58,6 @@ endef
TARGET_DEVICES += belkin_f5d8235-v1
define Device/buffalo_wli-tx4-ag300n
- BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WLI-TX4-AG300N
@@ -71,7 +68,6 @@ endef
TARGET_DEVICES += buffalo_wli-tx4-ag300n
define Device/buffalo_wzr-agl300nh
- BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WZR-AGL300NH
@@ -82,7 +78,6 @@ endef
TARGET_DEVICES += buffalo_wzr-agl300nh
define Device/dlink_dap-1522-a1
- BLOCKSIZE := 64k
IMAGE_SIZE := 3712k
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DAP-1522
@@ -98,7 +93,6 @@ endef
TARGET_DEVICES += dlink_dap-1522-a1
define Device/ralink_v11st-fe
- BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := V11ST-FE