aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-19 19:40:33 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-19 23:09:27 +0100
commite417ff88f19b90fc7badbb67b2e8c1760dd024dc (patch)
tree6c3597c0bf643b0ce48954306fd01af0684977f3 /target/linux/ramips/image/rt288x.mk
parentb70052c6e63f4fb3189ab2f9669c1fbd19478d79 (diff)
downloadupstream-e417ff88f19b90fc7badbb67b2e8c1760dd024dc.tar.gz
upstream-e417ff88f19b90fc7badbb67b2e8c1760dd024dc.tar.bz2
upstream-e417ff88f19b90fc7badbb67b2e8c1760dd024dc.zip
ramips: harmonize line breaks in image Makefiles
This harmonizes the line wrapping in image Makefile device definitions, as those are frequently copy-pasted and are a common subject of review comments. Having the treatment unifying should reduce the cases where adjustment is necessary afterwards. Harmonization is achieved by consistently (read "strictly") applying certain rules: - Never put more than 80 characters into one line - Fill lines up (do not break after 40 chars because of ...) - Use one tab for indent after wrapping by "\" - Only break after pipe "|" for IMAGE variables Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 460df28538..a66ee59881 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -53,7 +53,7 @@ define Device/belkin_f5d8235-v1
DEVICE_MODEL := F5D8235
DEVICE_VARIANT := V1
DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-ohci \
- kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+ kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += f5d8235-v1
endef
TARGET_DEVICES += belkin_f5d8235-v1
@@ -90,10 +90,8 @@ define Device/dlink_dap-1522-a1
DEVICE_PACKAGES := kmod-switch-rtl8366s
KERNEL := $(KERNEL_DTB)
IMAGES += factory.bin
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
- append-rootfs | pad-rootfs -x 96 | \
- wrg-header wapnd01_dlink_dap1522 | \
+ IMAGE/factory.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
+ append-rootfs | pad-rootfs -x 96 | wrg-header wapnd01_dlink_dap1522 | \
check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += dlink_dap-1522-a1