aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 21:54:50 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 17:16:11 +0100
commitdc862be3019299cc280053d73474c7f838ce15a0 (patch)
tree37b51c2e62053fcea7907a541d660e093d6f927c /target/linux/ramips/image/rt288x.mk
parentdaa218a28858ec4786fd22cb4f282754e4aab003 (diff)
downloadupstream-dc862be3019299cc280053d73474c7f838ce15a0.tar.gz
upstream-dc862be3019299cc280053d73474c7f838ce15a0.tar.bz2
upstream-dc862be3019299cc280053d73474c7f838ce15a0.zip
ramips: define SOC only once for uniform targets
In ramips, all devices in mt7621, mt76x8 and rt288x subtarget have the same value set to the SOC variable for each device individually. This patch introduces a non-device-dependent variable DEFAULT_SOC, which is used if no specific SOC is set for a device, and thus reduces the number of redundant definitions drastically. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk10
1 files changed, 2 insertions, 8 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 1b4880682a..800dc553a2 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -2,6 +2,8 @@
# RT288X Profiles
#
+DEFAULT_SOC := rt2880
+
define Build/gemtek-header
if [ -f $@ ]; then \
mkheader_gemtek $@ $@.new $(1) && \
@@ -10,7 +12,6 @@ define Build/gemtek-header
endef
define Device/airlink101_ar670w
- SOC := rt2880
BLOCKSIZE := 64k
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR670W
@@ -24,7 +25,6 @@ endef
TARGET_DEVICES += airlink101_ar670w
define Device/airlink101_ar725w
- SOC := rt2880
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR725W
@@ -36,7 +36,6 @@ endef
TARGET_DEVICES += airlink101_ar725w
define Device/asus_rt-n15
- SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
@@ -47,7 +46,6 @@ endef
TARGET_DEVICES += asus_rt-n15
define Device/belkin_f5d8235-v1
- SOC := rt2880
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F5D8235
@@ -59,7 +57,6 @@ endef
TARGET_DEVICES += belkin_f5d8235-v1
define Device/buffalo_wli-tx4-ag300n
- SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
@@ -70,7 +67,6 @@ endef
TARGET_DEVICES += buffalo_wli-tx4-ag300n
define Device/buffalo_wzr-agl300nh
- SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
@@ -81,7 +77,6 @@ endef
TARGET_DEVICES += buffalo_wzr-agl300nh
define Device/dlink_dap-1522-a1
- SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3712k
DEVICE_VENDOR := D-Link
@@ -97,7 +92,6 @@ endef
TARGET_DEVICES += dlink_dap-1522-a1
define Device/ralink_v11st-fe
- SOC := rt2880
BLOCKSIZE := 64k
IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink