aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-22 18:09:57 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:30 +0200
commit9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89 (patch)
tree5c4a1bf8f193064092d6559efc27c3c279c2f355 /target/linux/ramips/image/rt288x.mk
parent363197311b342a59b3c67e4bd2dfea3b3030b456 (diff)
downloadupstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.tar.gz
upstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.tar.bz2
upstream-9d87a58d347a299a8d3c27b038d5bb8a7d8d5b89.zip
ramips: remove ralink_default_fw_size_xxx variables
There are frequent examples of the ralink_default_fw_size_xxx variables being used to "roughly" set flash size without caring about the actual size of the firmware partition. To discourage this behavior, this patch removes the variables and just sets IMAGE_SIZE by its numeric value for each target. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index c1dd4a2db4..171edb2360 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -25,7 +25,7 @@ TARGET_DEVICES += airlink101_ar670w
define Device/airlink101_ar725w
MTK_SOC := rt2880
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Airlink
DEVICE_MODEL := AR725W
IMAGES += factory.bin
@@ -38,7 +38,7 @@ TARGET_DEVICES += airlink101_ar725w
define Device/asus_rt-n15
MTK_SOC := rt2880
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N15
DEVICE_PACKAGES := kmod-switch-rtl8366s
@@ -48,7 +48,7 @@ TARGET_DEVICES += asus_rt-n15
define Device/belkin_f5d8235-v1
MTK_SOC := rt2880
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ IMAGE_SIZE := 7872k
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F5D8235
DEVICE_VARIANT := V1
@@ -61,7 +61,7 @@ TARGET_DEVICES += belkin_f5d8235-v1
define Device/buffalo_wli-tx4-ag300n
MTK_SOC := rt2880
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WLI-TX4-AG300N
DEVICE_PACKAGES := kmod-switch-ip17xx
@@ -72,7 +72,7 @@ TARGET_DEVICES += buffalo_wli-tx4-ag300n
define Device/buffalo_wzr-agl300nh
MTK_SOC := rt2880
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WZR-AGL300NH
DEVICE_PACKAGES := kmod-switch-rtl8366s
@@ -101,7 +101,7 @@ TARGET_DEVICES += dlink_dap-1522-a1
define Device/ralink_v11st-fe
MTK_SOC := rt2880
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 3776k
DEVICE_VENDOR := Ralink
DEVICE_MODEL := V11ST-FE
SUPPORTED_DEVICES += v11st-fe