aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-03 09:56:35 +0200
committerMathias Kresin <dev@kresin.me>2016-09-03 09:56:35 +0200
commit28110727f1d513a6c4c13aa87ecb606aa5d306eb (patch)
tree395f63bd9844aa4228c041ea47fd2e0deac7befd /target/linux/ramips/image/rt288x.mk
parent05ab2323ffa4c630934e3d0b27a2516b26c1c161 (diff)
downloadupstream-28110727f1d513a6c4c13aa87ecb606aa5d306eb.tar.gz
upstream-28110727f1d513a6c4c13aa87ecb606aa5d306eb.tar.bz2
upstream-28110727f1d513a6c4c13aa87ecb606aa5d306eb.zip
ramips: set blocksize for 4MB devices
Set the blocksize for devices having only 4MB of flash for ramips devices already using the new image build code. Informations about the used flash chip are gathered from the OpenWrt wiki, wikidevi, forums, OEM bootlogs or the compatible property in the device tree source file. The en25q32b from the AirLive Air3GII does not have 4k support in the kernel. For the following boards no information about the used flash chip could be found and a 64k blocksize is assumed: - Ralink V11ST-FE - Ralink AP-RT3052-V22RW-2X2 - MediaTek MT7628 EVB - MediaTek MT7621 EVB - UPVEL UR-326N4G - Buffalo WZR-AGL300NH Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index ebb523e461..7e7652e9ec 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -15,6 +15,7 @@ endef
define Device/ar670w
DTS := AR670W
+ BLOCKSIZE := 64k
DEVICE_TITLE := Airlink AR670W
IMAGE_SIZE := $(ralink_default_fw_size_4M)
KERNEL := $(KERNEL_DTB)
@@ -41,6 +42,7 @@ TARGET_DEVICES += f5d8235v1
define Device/rt-n15
DTS := RT-N15
+ BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Asus RT-N15
DEVICE_PACKAGES := kmod-switch-rtl8366s
@@ -49,6 +51,7 @@ TARGET_DEVICES += rt-n15
define Device/v11st-fe
DTS := V11STFE
+ BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Ralink V11ST-FE
endef
@@ -56,6 +59,7 @@ TARGET_DEVICES += v11st-fe
define Device/wli-tx4-ag300n
DTS := WLI-TX4-AG300N
+ BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Buffalo WLI-TX4-AG300N
endef
@@ -63,6 +67,7 @@ TARGET_DEVICES += wli-tx4-ag300n
define Device/wzr-agl300nh
DTS := WZR-AGL300NH
+ BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Buffalo WZR-AGL300NH
DEVICE_PACKAGES := kmod-switch-rtl8366s