aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt288x.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-07 16:27:51 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 17:36:29 +0200
commit447deed52abaa1b51d1753acded2eeb119c70136 (patch)
treea627671dc88b02fcf019d739880eba1253fed7e7 /target/linux/ramips/image/rt288x.mk
parent5d50155f14b2974d422c97eac2c7efa437efc4e3 (diff)
downloadupstream-447deed52abaa1b51d1753acded2eeb119c70136.tar.gz
upstream-447deed52abaa1b51d1753acded2eeb119c70136.tar.bz2
upstream-447deed52abaa1b51d1753acded2eeb119c70136.zip
ramips: Sort all subtarget Makefiles
This patch applies sorting to the definitions as whole blocks. Sorting has been performed fully automatic, line count differences originate from double empty lines removed. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/rt288x.mk')
-rw-r--r--target/linux/ramips/image/rt288x.mk68
1 files changed, 34 insertions, 34 deletions
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index e8e51adc31..8d7e926286 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -34,23 +34,16 @@ define Device/airlink101_ar725w
endef
TARGET_DEVICES += airlink101_ar725w
-define Device/dlink_dap-1522-a1
+define Device/asus_rt-n15
MTK_SOC := rt2880
BLOCKSIZE := 64k
- IMAGE_SIZE := 3801088
- DEVICE_VENDOR := D-Link
- DEVICE_MODEL := DAP-1522
- DEVICE_VARIANT := A1
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_VENDOR := Asus
+ DEVICE_MODEL := RT-N15
DEVICE_PACKAGES := kmod-switch-rtl8366s
- KERNEL := $(KERNEL_DTB)
- IMAGES += factory.bin
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
- append-rootfs | pad-rootfs -x 96 | \
- wrg-header wapnd01_dlink_dap1522 | \
- check-size $$$$(IMAGE_SIZE)
+ SUPPORTED_DEVICES += rt-n15
endef
-TARGET_DEVICES += dlink_dap-1522-a1
+TARGET_DEVICES += asus_rt-n15
define Device/belkin_f5d8235-v1
MTK_SOC := rt2880
@@ -64,27 +57,6 @@ define Device/belkin_f5d8235-v1
endef
TARGET_DEVICES += belkin_f5d8235-v1
-define Device/asus_rt-n15
- MTK_SOC := rt2880
- BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
- DEVICE_VENDOR := Asus
- DEVICE_MODEL := RT-N15
- DEVICE_PACKAGES := kmod-switch-rtl8366s
- SUPPORTED_DEVICES += rt-n15
-endef
-TARGET_DEVICES += asus_rt-n15
-
-define Device/ralink_v11st-fe
- MTK_SOC := rt2880
- BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
- DEVICE_VENDOR := Ralink
- DEVICE_MODEL := V11ST-FE
- SUPPORTED_DEVICES += v11st-fe
-endef
-TARGET_DEVICES += ralink_v11st-fe
-
define Device/buffalo_wli-tx4-ag300n
MTK_SOC := rt2880
BLOCKSIZE := 64k
@@ -106,3 +78,31 @@ define Device/buffalo_wzr-agl300nh
SUPPORTED_DEVICES += wzr-agl300nh
endef
TARGET_DEVICES += buffalo_wzr-agl300nh
+
+define Device/dlink_dap-1522-a1
+ MTK_SOC := rt2880
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 3801088
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-1522
+ DEVICE_VARIANT := A1
+ DEVICE_PACKAGES := kmod-switch-rtl8366s
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
+ append-rootfs | pad-rootfs -x 96 | \
+ wrg-header wapnd01_dlink_dap1522 | \
+ check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += dlink_dap-1522-a1
+
+define Device/ralink_v11st-fe
+ MTK_SOC := rt2880
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ DEVICE_VENDOR := Ralink
+ DEVICE_MODEL := V11ST-FE
+ SUPPORTED_DEVICES += v11st-fe
+endef
+TARGET_DEVICES += ralink_v11st-fe