aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorJo Deisenhofer <jo.deisenhofer@gmail.com>2022-12-02 16:41:13 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-14 19:02:21 +0100
commitf204c812e996d51f36972d5f4414ada3d4588c93 (patch)
treedb05fd7d88d5923a72ca167f526093b5013a3cee /target/linux/ramips/image/mt76x8.mk
parentab402f3d23223b23f622a69e1afa570cfef16099 (diff)
downloadupstream-f204c812e996d51f36972d5f4414ada3d4588c93.tar.gz
upstream-f204c812e996d51f36972d5f4414ada3d4588c93.tar.bz2
upstream-f204c812e996d51f36972d5f4414ada3d4588c93.zip
ramips: add support for xiaomi RA75 Range Extender
This device is a 'Range extender' variant of the Xiaomi 4A router. Its identical to the 100m non-intl/chinese version as much as it can run the same firmware, differences being form factor, LEDs, WPS button and one 100M port only. The stock firmware differs significantly, being 'app managed only'. Device specification -------------------- SoC: MT7628DAN MIPS_24KEc@580MHz 2.4G-n 2x2 WiFi: MT7612EN 5G-ac 80MHz 2T2R Flash: 16MB W25Q128BV DRAM: 64MB built-in SoC Switch: built-in SoC Ethernet: 1x10/100 Mbps USB: None Antennas: 2 x external, non-detachable LEDs: 2 programmable blue/amber Buttons: WPS and reset (hidden) Housing: Range Extender / Wall wart Serial: 115200,8n1 MAC Addresses ------------- All 3 MACs are read from flash and identical to stock. Label MAC is WIFI 2G Installation ------------ No HTML UI on this device, serial console only. The serial connector is unpopulated but standard size and clearly marked. Flash from the U-Boot shell at boot by choosing (2) and flashing the sysupgrade file via tftp. Recovery/Debricking procedures of the xiaomi 4A and variants should work, but there currently is no official source for the stock firmware. Signed-off-by: Jo Deisenhofer <jo.deisenhofer@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 9db2d9e60c..f482872813 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -1011,6 +1011,16 @@ define Device/xiaomi_miwifi-nano
endef
TARGET_DEVICES += xiaomi_miwifi-nano
+define Device/xiaomi_mi-ra75
+ IMAGE_SIZE := 14976k
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_MODEL := MiWiFi Range Extender AC1200
+ DEVICE_VARIANT := RA75
+ DEVICE_PACKAGES := kmod-mt76x2
+ SUPPORTED_DEVICES += xiaomi,mira75
+endef
+TARGET_DEVICES += xiaomi_mi-ra75
+
define Device/zbtlink_zbt-we1226
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Zbtlink