aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorSenis John <thank243@gmail.com>2022-11-19 11:30:54 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-12-04 15:21:12 +0800
commita8f3c97ce83dc97cd7acb040a715ecd75d824161 (patch)
treebc758250d6507cac84c155bc5eb939a22dcc1cf7 /target/linux/ramips/image/mt76x8.mk
parentd11d93b9ae8cd59e9f8ea09b7f125a2f9569846c (diff)
downloadupstream-a8f3c97ce83dc97cd7acb040a715ecd75d824161.tar.gz
upstream-a8f3c97ce83dc97cd7acb040a715ecd75d824161.tar.bz2
upstream-a8f3c97ce83dc97cd7acb040a715ecd75d824161.zip
ramips: add support for HiWiFi HC5611
CPU: MediaTek MT7628AN @ 575 MHz Flash: 16 MB RAM: 128 MB Ethernet: 10/100Mbps x 1 Wlan: 300 Mbps USB: USB 2.0 x 1 LED: red/green x 1 Button: reset x 1 1. Open https://www.hiwifi.wtf/, Get Cloud token and unlock ssh 2. Upload the openwrt firmware to the router via SCP 3. Login the router via SSH 4. Run `mtd -r write path_to_firmware.bin firmware` I have tested on my device. - The LED will display RED on power-on, After system start completed, trun GREEN - Reset button working now. Long press after 5s will reset factory. Short press less 1s will reboot the device - USB can working under official u-boot Signed-off-by: Senis John <thank243@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5e8d05b042..1b7e786b52 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -243,6 +243,14 @@ define Device/hilink_hlk-7688a
endef
TARGET_DEVICES += hilink_hlk-7688a
+define Device/hiwifi_hc5611
+ IMAGE_SIZE := 15808k
+ DEVICE_VENDOR := HiWiFi
+ DEVICE_MODEL := HC5611
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += hiwifi_hc5611
+
define Device/hiwifi_hc5661a
IMAGE_SIZE := 15808k
DEVICE_VENDOR := HiWiFi