aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorNita Vesa <werecatf@outlook.com>2022-04-29 13:57:24 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-03 22:14:05 +0200
commit1a8c74da709190e5157af9f5c2502b600f6273bb (patch)
tree6bcbd9da810ae229d9e7674bd253b70c5148c31c /target/linux/ramips/image/mt76x8.mk
parent4b0c433c39fc1aa28ba0af01987017330d555379 (diff)
downloadupstream-1a8c74da709190e5157af9f5c2502b600f6273bb.tar.gz
upstream-1a8c74da709190e5157af9f5c2502b600f6273bb.tar.bz2
upstream-1a8c74da709190e5157af9f5c2502b600f6273bb.zip
ramips: Add Xiaomi Mi Router 4A 100M International
The international version of Mi Router 4A 100M is physically identical to the non-international one, but appears to be using a different partitioning scheme with the "overlay" partition being 2MiB in size instead of 1MiB. This means the following "firmware" partition starts at a different address and the DTS needs to be adjusted for the firmware to work. Signed-off-by: Nita Vesa <werecatf@outlook.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5c10159568..21126c32d9 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -917,6 +917,16 @@ define Device/xiaomi_mi-router-4a-100m
endef
TARGET_DEVICES += xiaomi_mi-router-4a-100m
+define Device/xiaomi_mi-router-4a-100m-intl
+ IMAGE_SIZE := 14976k
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_MODEL := Mi Router 4A
+ DEVICE_VARIANT := 100M International Edition
+ DEVICE_PACKAGES := kmod-mt76x2
+ SUPPORTED_DEVICES += xiaomi,mir4a-100m-intl
+endef
+TARGET_DEVICES += xiaomi_mi-router-4a-100m-intl
+
define Device/xiaomi_mi-router-4c
IMAGE_SIZE := 14976k
DEVICE_VENDOR := Xiaomi