aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 22:58:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 20:02:55 +0100
commit3f14f034fb5e191f4a537998379d8e922ec31e8a (patch)
tree2daa222bf570dcd278377f8fe4c8969a92d4ead0 /target/linux/ramips/image/mt76x8.mk
parent1444e31a7bf54b796f8ef88e77fee255b959c6bb (diff)
downloadupstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.gz
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.bz2
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.zip
treewide: omit IMAGE_SIZE argument from check-size
Now that check-size uses IMAGE_SIZE by default, we can skip the argument from image recipes to reduce redundancy. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 51f630f42a..e2890c98e6 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -34,7 +34,7 @@ TARGET_DEVICES += buffalo_wcr-1166ds
define Device/cudy_wr1000
IMAGE_SIZE := 7872k
IMAGES += factory.bin
- IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
jcg-header 92.122
JCG_MAXSIZE := 7872k
DEVICE_VENDOR := Cudy
@@ -180,7 +180,7 @@ define Device/netgear_r6120
IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE)| append-rootfs | \
pad-rootfs
IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
IMAGE/factory.img := pad-extra 576k | $$(IMAGE/default) | \
pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | zip R6120.bin | \
sercom-seal
@@ -592,6 +592,6 @@ define Device/zyxel_keenetic-extra-ii
kmod-usb-ledtrig-usbport
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to $$$$(BLOCKSIZE) | \
- check-size $$$$(IMAGE_SIZE) | zyimage -d 6162 -v "ZyXEL Keenetic Extra II"
+ check-size | zyimage -d 6162 -v "ZyXEL Keenetic Extra II"
endef
TARGET_DEVICES += zyxel_keenetic-extra-ii