aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-09 18:40:01 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-12 22:27:18 +0800
commitd7d46da938e3f5c4ace815870c95f67d8b663ebe (patch)
treea98918ad84f4744246d07fd5a3c0426de8aee8d0 /target/linux/ramips/image/mt76x8.mk
parente29e2a94845141e5c9758351c7dffa1145c5d3b5 (diff)
downloadupstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.tar.gz
upstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.tar.bz2
upstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.zip
ramips: disable images for 4M devices
default initramfs for 5.4 kernel is larger than 4M, causing build error for oversized initramfs image. disable these images because we have no mechanism for ignoring initramfs errors and the squashfs image will be larger than initramfs anyway. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index e2890c98e6..76fcab8787 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -405,6 +405,7 @@ define Device/tplink_tl-wr840n-v5
TPLINK_HWREVADD := 0x5
IMAGES := sysupgrade.bin
SUPPORTED_DEVICES += tl-wr840n-v5
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr840n-v5
@@ -433,6 +434,7 @@ define Device/tplink_tl-wr841n-v14
TPLINK_HWREVADD := 0x14
IMAGES := sysupgrade.bin tftp-recovery.bin
IMAGE/tftp-recovery.bin := pad-extra 64k | $$(IMAGE/factory.bin)
+ DEFAULT := n
endef
TARGET_DEVICES += tplink_tl-wr841n-v14