aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorGiovanni Cascione <ing.cascione@gmail.com>2021-07-08 18:30:53 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-25 01:42:17 +0200
commitd57ba86e489e363be3b26b9cb880048da5dfd12c (patch)
tree4d1f75999c77e273e51e7496d1848b20b314f25c /target/linux/ramips/image/mt76x8.mk
parente2d08084c30e1f25559bfc1c745c0d0854a75636 (diff)
downloadupstream-d57ba86e489e363be3b26b9cb880048da5dfd12c.tar.gz
upstream-d57ba86e489e363be3b26b9cb880048da5dfd12c.tar.bz2
upstream-d57ba86e489e363be3b26b9cb880048da5dfd12c.zip
ramips: add support for D-Link DAP-1325-A1
This patch adds support for D-Link DAP-1325-A1 (Range Extender Wi-Fi N300) Specifications: - SoC: 580Mhz MT7628NN - RAM: 64MB, DDR2 SDRAM - Storage: 8MB, SPI (W25Q64JVSSIQ) - Ethernet: 1x 10/100 LAN port - WIFI: 2.4 GHz 802.11bgn - LED: Status (2x to provide 3 colors), Wi-Fi Signal Strength (4x) - Buttons: Reset, WPS - UART: Serial console (57600, 8n1) Row of 4 holes near LAN port, starting from square hole: 3.3V, TX,RX,GND - FCC ID: fccid.io/KA2AP1325A1/ Installation: Failsafe UI Firmware can be uploaded with Failsafe UI web page: - turn device off - press and hold reset button - turn device on - keep holding reset until red wifi strength led turns on (ab. 10sec) - connect to device through LAN port PC must be configured with static ip (192.168.0.x) - connect to 192.168.0.50 - select image to be flashed and upload. Device will reboot after successful update Serial port/TFTP server - Connect through serial connectors on PCB (e.g. with teraterm) - Set up a TFTP server, and connect through LAN with static IP - Put image file in the root of the server - Boot the device and select '2' at U-Boot startup - Set device IP, server IP and image file name - Start upload and flash Signed-off-by: Giovanni Cascione <ing.cascione@gmail.com> [fix whitespaces in DTS, convert to nvmem, add mtd-eeprom] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index f63930adb1..7862f7b799 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -100,6 +100,13 @@ define Device/d-team_pbr-d1
endef
TARGET_DEVICES += d-team_pbr-d1
+define Device/dlink_dap-1325-a1
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-1325 A1
+endef
+TARGET_DEVICES += dlink_dap-1325-a1
+
define Device/duzun_dm06
IMAGE_SIZE := 7872k
DEVICE_VENDOR := DuZun