aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-13 04:19:32 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 14:05:00 +0100
commit6410c30dc7cefdf06dca1e09d1c337138aa4abea (patch)
tree25ead09721a462cb6c9b9eb917b94b5dac95d6c2 /target/linux/ramips/image/mt76x8.mk
parentb9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b (diff)
downloadupstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.tar.gz
upstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.tar.bz2
upstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.zip
ramips: add support for TOTOLINK A3
TOTOLINK A3 is a clone of ipTIME A3. The only difference is the model name. Specifications: - SoC: MT7628AN - RAM: DDR2 64MB - Flash: SPI NOR 8MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7612EN - Ethernet: 3x 10/100Mbps - Switch: SoC internal Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Tested on device by JasonHCH <hsuan670629@gmail.com> Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index faa2ca1c5a..51f630f42a 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -229,6 +229,15 @@ define Device/tama_w06
endef
TARGET_DEVICES += tama_w06
+define Device/totolink_a3
+ IMAGE_SIZE := 7936k
+ UIMAGE_NAME := za3
+ DEVICE_VENDOR := TOTOLINK
+ DEVICE_MODEL := A3
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += totolink_a3
+
define Device/totolink_lr1200
IMAGE_SIZE := 7872k
DEVICE_VENDOR := TOTOLINK