aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2021-08-24 22:59:59 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-25 01:41:35 +0200
commit09143282bde3abd560a3b70f76df6d77b6ac6f12 (patch)
treee8f4b8a54af3a34797eb31efeea144aa76c08e9a /target/linux/ramips/image/mt76x8.mk
parentfcc075e12f6f4718ccac6b5eb68cb8346064ee43 (diff)
downloadupstream-09143282bde3abd560a3b70f76df6d77b6ac6f12.tar.gz
upstream-09143282bde3abd560a3b70f76df6d77b6ac6f12.tar.bz2
upstream-09143282bde3abd560a3b70f76df6d77b6ac6f12.zip
ramips: add support for Motorola MWR03
Specifications: * SOC: MT7628AN + MT7612E * ROM: 8 MiB Flash * RAM: 64 MiB DDR2 * WAN: 10/100M *1 * LAN: 10/100M *3 * Button: Reset *1 * LEDs: orange *1, white *1 * Antennas: 2.4 GHz *2 + 5 GHz *2 * TTL Baudrate: 57600 * TFTP Upgrade: IP: 192.168.51.1, Server: 192.168.51.100 MAC addresses as verified by OEM firmware: use address source 2g *:d8 factory 0x0004 (label) 5g *:d9 factory 0x8004 LAN *:d7 factory $label -1 WAN *:da factory $label +2 Installation (TFTP + U-Boot): * Connect device with a TTL cable and open a serial session by PuTTY. * Press "2" when booting to select "Load system code then write to Flash via TFTP". * Configure the IP of local host server. * Upload firmware by tftpd64, it will boot when write instruction is executed. Signed-off-by: Shiji Yang <yangshiji66@qq.com> [fix DTS line endings, fix label MAC address, adjust status LED names, convert mtd-mac-address-increment to mac-address-increment] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 3f6f842db7..f63930adb1 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -278,6 +278,14 @@ define Device/minew_g1-c
endef
TARGET_DEVICES += minew_g1-c
+define Device/motorola_mwr03
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Motorola
+ DEVICE_MODEL := MWR03
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += motorola_mwr03
+
define Device/netgear_r6020
$(Device/netgear_sercomm_nor)
IMAGE_SIZE := 7104k