aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 21:54:50 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 17:16:11 +0100
commitdc862be3019299cc280053d73474c7f838ce15a0 (patch)
tree37b51c2e62053fcea7907a541d660e093d6f927c /target/linux/ramips/image/mt76x8.mk
parentdaa218a28858ec4786fd22cb4f282754e4aab003 (diff)
downloadupstream-dc862be3019299cc280053d73474c7f838ce15a0.tar.gz
upstream-dc862be3019299cc280053d73474c7f838ce15a0.tar.bz2
upstream-dc862be3019299cc280053d73474c7f838ce15a0.zip
ramips: define SOC only once for uniform targets
In ramips, all devices in mt7621, mt76x8 and rt288x subtarget have the same value set to the SOC variable for each device individually. This patch introduces a non-device-dependent variable DEFAULT_SOC, which is used if no specific SOC is set for a device, and thus reduces the number of redundant definitions drastically. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk42
1 files changed, 2 insertions, 40 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index fe08c77c13..5ddeec14d5 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -2,8 +2,9 @@
# MT76x8 Profiles
#
+DEFAULT_SOC := mt7628an
+
define Device/alfa-network_awusfree1
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AWUSFREE1
@@ -12,7 +13,6 @@ endef
TARGET_DEVICES += alfa-network_awusfree1
define Device/buffalo_wcr-1166ds
- SOC := mt7628an
IMAGE_SIZE := 7936k
BUFFALO_TAG_PLATFORM := MTK
BUFFALO_TAG_VERSION := 9.99
@@ -30,7 +30,6 @@ endef
TARGET_DEVICES += buffalo_wcr-1166ds
define Device/cudy_wr1000
- SOC := mt7628an
IMAGE_SIZE := 7872k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -44,7 +43,6 @@ endef
TARGET_DEVICES += cudy_wr1000
define Device/d-team_pbr-d1
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := PandoraBox
DEVICE_MODEL := PBR-D1
@@ -54,7 +52,6 @@ endef
TARGET_DEVICES += d-team_pbr-d1
define Device/duzun_dm06
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := DuZun
DEVICE_MODEL := DM06
@@ -64,7 +61,6 @@ endef
TARGET_DEVICES += duzun_dm06
define Device/glinet_gl-mt300n-v2
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := GL.iNet
DEVICE_MODEL := GL-MT300N
@@ -75,7 +71,6 @@ endef
TARGET_DEVICES += glinet_gl-mt300n-v2
define Device/glinet_vixmini
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := GL.iNet
DEVICE_MODEL := VIXMINI
@@ -84,7 +79,6 @@ endef
TARGET_DEVICES += glinet_vixmini
define Device/hilink_hlk-7628n
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := HILINK
DEVICE_MODEL := HLK-7628N
@@ -92,7 +86,6 @@ endef
TARGET_DEVICES += hilink_hlk-7628n
define Device/hiwifi_hc5661a
- SOC := mt7628an
IMAGE_SIZE := 15808k
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5661A
@@ -101,7 +94,6 @@ endef
TARGET_DEVICES += hiwifi_hc5661a
define Device/hiwifi_hc5761a
- SOC := mt7628an
IMAGE_SIZE := 15808k
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5761A
@@ -110,7 +102,6 @@ endef
TARGET_DEVICES += hiwifi_hc5761a
define Device/hiwifi_hc5861b
- SOC := mt7628an
IMAGE_SIZE := 15808k
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5861B
@@ -119,7 +110,6 @@ endef
TARGET_DEVICES += hiwifi_hc5861b
define Device/iptime_a3
- SOC := mt7628an
IMAGE_SIZE := 7936k
UIMAGE_NAME := a3
DEVICE_VENDOR := ipTIME
@@ -129,7 +119,6 @@ endef
TARGET_DEVICES += iptime_a3
define Device/iptime_a604m
- SOC := mt7628an
IMAGE_SIZE := 7936k
UIMAGE_NAME := a604m
DEVICE_VENDOR := ipTIME
@@ -139,7 +128,6 @@ endef
TARGET_DEVICES += iptime_a604m
define Device/mediatek_linkit-smart-7688
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := LinkIt Smart 7688
@@ -149,7 +137,6 @@ endef
TARGET_DEVICES += mediatek_linkit-smart-7688
define Device/mediatek_mt7628an-eval-board
- SOC := mt7628an
BLOCKSIZE := 64k
IMAGE_SIZE := 7872k
DEVICE_VENDOR := MediaTek
@@ -160,7 +147,6 @@ endef
TARGET_DEVICES += mediatek_mt7628an-eval-board
define Device/mercury_mac1200r-v2
- SOC := mt7628an
IMAGE_SIZE := 7936k
DEVICE_VENDOR := Mercury
DEVICE_MODEL := MAC1200R
@@ -172,7 +158,6 @@ endef
TARGET_DEVICES += mercury_mac1200r-v2
define Device/netgear_r6120
- SOC := mt7628an
BLOCKSIZE := 64k
IMAGE_SIZE := 15744k
DEVICE_VENDOR := NETGEAR
@@ -193,7 +178,6 @@ endef
TARGET_DEVICES += netgear_r6120
define Device/onion_omega2
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Onion
DEVICE_MODEL := Omega2
@@ -203,7 +187,6 @@ endef
TARGET_DEVICES += onion_omega2
define Device/onion_omega2p
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Onion
DEVICE_MODEL := Omega2+
@@ -213,7 +196,6 @@ endef
TARGET_DEVICES += onion_omega2p
define Device/rakwireless_rak633
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Rakwireless
DEVICE_MODEL := RAK633
@@ -222,7 +204,6 @@ endef
TARGET_DEVICES += rakwireless_rak633
define Device/skylab_skw92a
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Skylab
DEVICE_MODEL := SKW92A
@@ -231,7 +212,6 @@ endef
TARGET_DEVICES += skylab_skw92a
define Device/tama_w06
- SOC := mt7628an
IMAGE_SIZE := 15040k
DEVICE_VENDOR := Tama
DEVICE_MODEL := W06
@@ -240,7 +220,6 @@ endef
TARGET_DEVICES += tama_w06
define Device/totolink_lr1200
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := TOTOLINK
DEVICE_MODEL := LR1200
@@ -249,7 +228,6 @@ endef
TARGET_DEVICES += totolink_lr1200
define Device/tplink
- SOC := mt7628an
DEVICE_VENDOR := TP-Link
TPLINK_FLASHLAYOUT :=
TPLINK_HWID :=
@@ -268,7 +246,6 @@ DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD
DEVICE_VARS += TPLINK_HVERSION
define Device/tplink-safeloader
- SOC := mt7628an
DEVICE_VENDOR := TP-Link
TPLINK_BOARD_ID :=
TPLINK_HWID := 0x0
@@ -421,7 +398,6 @@ endef
TARGET_DEVICES += tplink_tl-wr840n-v4
define Device/tplink_tl-wr840n-v5
- SOC := mt7628an
IMAGE_SIZE := 3904k
DEVICE_VENDOR := TP-Link
DEVICE_MODEL := TL-WR840N
@@ -497,7 +473,6 @@ endef
TARGET_DEVICES += tplink_tl-wr902ac-v3
define Device/unielec_u7628-01-16m
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7628-01
@@ -508,7 +483,6 @@ endef
TARGET_DEVICES += unielec_u7628-01-16m
define Device/vocore_vocore2
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := VoCore
DEVICE_MODEL := VoCore2
@@ -519,7 +493,6 @@ endef
TARGET_DEVICES += vocore_vocore2
define Device/vocore_vocore2-lite
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := VoCore
DEVICE_MODEL := VoCore2-Lite
@@ -530,7 +503,6 @@ endef
TARGET_DEVICES += vocore_vocore2-lite
define Device/wavlink_wl-wn570ha1
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Wavlink
DEVICE_MODEL := WL-WN570HA1
@@ -539,7 +511,6 @@ endef
TARGET_DEVICES += wavlink_wl-wn570ha1
define Device/wavlink_wl-wn575a3
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Wavlink
DEVICE_MODEL := WL-WN575A3
@@ -549,7 +520,6 @@ endef
TARGET_DEVICES += wavlink_wl-wn575a3
define Device/widora_neo-16m
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Widora
DEVICE_MODEL := Widora-NEO
@@ -560,7 +530,6 @@ endef
TARGET_DEVICES += widora_neo-16m
define Device/widora_neo-32m
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Widora
DEVICE_MODEL := Widora-NEO
@@ -570,7 +539,6 @@ endef
TARGET_DEVICES += widora_neo-32m
define Device/wiznet_wizfi630s
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := WIZnet
DEVICE_MODEL := WizFi630S
@@ -578,7 +546,6 @@ endef
TARGET_DEVICES += wiznet_wizfi630s
define Device/wrtnode_wrtnode2p
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := WRTnode
DEVICE_MODEL := WRTnode 2P
@@ -588,7 +555,6 @@ endef
TARGET_DEVICES += wrtnode_wrtnode2p
define Device/wrtnode_wrtnode2r
- SOC := mt7628an
IMAGE_SIZE := 32448k
DEVICE_VENDOR := WRTnode
DEVICE_MODEL := WRTnode 2R
@@ -598,7 +564,6 @@ endef
TARGET_DEVICES += wrtnode_wrtnode2r
define Device/xiaomi_mir4a-100m
- SOC := mt7628an
IMAGE_SIZE := 14976k
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router 4A
@@ -608,7 +573,6 @@ endef
TARGET_DEVICES += xiaomi_mir4a-100m
define Device/xiaomi_miwifi-nano
- SOC := mt7628an
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := MiWiFi Nano
@@ -618,7 +582,6 @@ endef
TARGET_DEVICES += xiaomi_miwifi-nano
define Device/zbtlink_zbt-we1226
- SOC := mt7628an
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WE1226
@@ -626,7 +589,6 @@ endef
TARGET_DEVICES += zbtlink_zbt-we1226
define Device/zyxel_keenetic-extra-ii
- SOC := mt7628an
IMAGE_SIZE := 14912k
BLOCKSIZE := 64k
DEVICE_VENDOR := ZyXEL