aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorLiu Yu <f78fk@live.com>2019-05-05 10:54:52 +0800
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 13:43:55 +0200
commit671c9d16e382bcace441d8ad07816f8ceeed3612 (patch)
tree749a577c94524d8bbd8d15e934f1d0d96ff98013 /target/linux/ramips/image/mt76x8.mk
parent30dcbc741d84e36ea5408d99593ccb35f900cb5e (diff)
downloadupstream-671c9d16e382bcace441d8ad07816f8ceeed3612.tar.gz
upstream-671c9d16e382bcace441d8ad07816f8ceeed3612.tar.bz2
upstream-671c9d16e382bcace441d8ad07816f8ceeed3612.zip
ramips: add support for HILINK HLK-7628N
Specification: CPU: MT7628 580 MHz. MIPS 24K RAM: 128 MB Flash: 32 MB WIFI: 802.11n/g/b 20/40 MHz Ethernet: 5 Port ethernet switch UART: 2x Flash instruction: The U-boot is based on Ralink SDK so we can flash the firmware using UART: 1. Configure PC with a static IP address and setup an TFTP server. 2. Put the firmware into the tftp directory. 3. Connect the UART0 line as described on the PCB. 4. Power up the device and press 2, follow the instruction to set device and tftp server IP address and input the firmware file name. U-boot will then load the firmware and write it into the flash. 5. After firmware is started connect via ethernet at 192.168.1.1 Signed-off-by: Liu Yu <f78fk@live.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [removed dupped subject]
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index ba3354a8a6..0fd72a4117 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -81,6 +81,13 @@ define Device/hc5661a
endef
TARGET_DEVICES += hc5661a
+define Device/hilink_hlk-7628n
+ DTS := HLK-7628N
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := HILINK HLK7628N
+endef
+TARGET_DEVICES += hilink_hlk-7628n
+
define Device/hiwifi_hc5861b
DTS := HC5861B
IMAGE_SIZE := 15808k