aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-08-18 14:50:20 +0900
committerChuanhong Guo <gch981213@gmail.com>2019-09-25 14:44:36 +0800
commitb7ec6659a14d1a11e52b56235274b3e46d22e331 (patch)
tree51db015026405038ce078e61194ff695f7736cae /target/linux/ramips/image/mt76x8.mk
parent93b6cc97ca9694434faef69c6c5145b5dc7c1ae4 (diff)
downloadupstream-b7ec6659a14d1a11e52b56235274b3e46d22e331.tar.gz
upstream-b7ec6659a14d1a11e52b56235274b3e46d22e331.tar.bz2
upstream-b7ec6659a14d1a11e52b56235274b3e46d22e331.zip
ramips: add support for ipTIME A3
ipTIME A3 is a 2.4/5GHz band AC1200 router, based on MediaTek MT7628AN. Specifications: - SoC: MT7628AN - RAM: DDR2 64MB - Flash: SPI NOR 8MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7612EN - Ethernet: 3x 10/100Mbps - Switch: SoC internal - UART: - J1: 3.3V, TX, RX, GND (3.3V is the square pad) / 57600 8N1 Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 76d4c635d4..3179adc472 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -120,6 +120,16 @@ define Device/hiwifi_hc5861b
endef
TARGET_DEVICES += hiwifi_hc5861b
+define Device/iptime_a3
+ MTK_SOC := mt7628an
+ IMAGE_SIZE := 7936k
+ UIMAGE_NAME := a3
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A3
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += iptime_a3
+
define Device/iptime_a604m
MTK_SOC := mt7628an
IMAGE_SIZE := 7936k