aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorAlexander Müller <donothingloop@gmail.com>2018-11-27 15:32:18 +0100
committerAlexander Couzens <lynxis@fe80.eu>2019-07-02 16:17:49 +0200
commit3fd97c522bb791058215e736a00b86aa8af92363 (patch)
tree9a553efa1ffbc73861a6b2dd72e132cef2be2ffb /target/linux/ramips/image/mt76x8.mk
parentcc1147072d24eab3dfc802ceeb237fbeb584d946 (diff)
downloadupstream-3fd97c522bb791058215e736a00b86aa8af92363.tar.gz
upstream-3fd97c522bb791058215e736a00b86aa8af92363.tar.bz2
upstream-3fd97c522bb791058215e736a00b86aa8af92363.zip
ramips: add support for TP-Link TL-WR841n v14
TP-Link TL-WR841n v14 is a router based on MediaTek MT7628N. - MediaTek MT7628NN - 32 MB of RAM - 4 MB of FLASH - 2T2R 2.4 GHz - 5x 10/100 Mbps Ethernet Installation: - copy the 'openwrt-ramips-mt76x8-tl-wr841n-v14-squashfs-tftp-recovery.bin' file to your tftp server root and rename it to 'tp_recovery.bin'. - configure your PC running the TFTP server with the static IP address 192.168.0.66/24 - push the reset button and plug in the power connector. Wait until the orange led starts blinking (~6sec) Signed-off-by: Alexander Müller <donothingloop@gmail.com> Signed-off-by: Alexander Couzens <lynxis@fe80.eu> [small modifications gpio-hog]
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 2280a1a618..266df857a3 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -259,6 +259,20 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_tl-wr841n-v14
+ $(Device/tplink)
+ DTS := TL-WR841NV14
+ IMAGE_SIZE := 3968k
+ DEVICE_TITLE := TP-Link TL-WR841N v14
+ TPLINK_FLASHLAYOUT := 4Mmtk
+ TPLINK_HWID := 0x08410014
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x14
+ TPLINK_HVERSION := 3
+ IMAGE/tftp-recovery.bin := pad-extra 64k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-wr841n-v14
+
define Device/tplink_c20-v4
$(Device/tplink)
DTS := ArcherC20v4