aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:27 +0200
commit363197311b342a59b3c67e4bd2dfea3b3030b456 (patch)
tree011d1f66850ea187a3e74f3badec2d108e705234 /target/linux/ramips/image/mt76x8.mk
parent24ded1810b071ec7e7c8d134e5491d9649c13dac (diff)
downloadupstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.gz
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.bz2
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.zip
ramips: remove default IMAGE_SIZE for ramips target
Currently, ramips target defines 0x7b0000 as default IMAGE_SIZE for all devices in ramips target, i.e. this will be set if a device does not specify IMAGE_SIZE itself. From 92 devices using that default due to a "missing" IMAGE_SIZE, 14 were incorrect by a small amount (i.e. still "8M" flash) and 12 were completely off ("16M", "4M", ...). This patch thus removes the _default_ IMAGE_SIZE and defines IMAGE_SIZE for each device individually. This should indicate to people supporting new devices that this parameter has to be cared about. For the present code, this patch is cosmetical. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 8bcd96cc71..ceb124569b 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -57,6 +57,7 @@ TARGET_DEVICES += d-team_pbr-d1
define Device/duzun_dm06
MTK_SOC := mt7628an
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
DEVICE_VENDOR := DuZun
DEVICE_MODEL := DM06
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
@@ -183,6 +184,7 @@ TARGET_DEVICES += onion_omega2p
define Device/rakwireless_rak633
MTK_SOC := mt7628an
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
DEVICE_VENDOR := Rakwireless
DEVICE_MODEL := RAK633
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci