aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-01-26 16:21:34 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 23:40:11 +0100
commitf1c193c27e714a051b49788fff3aecbd728190e1 (patch)
tree96de333820159b99516114bf11b68b361674c351 /target/linux/ramips/image/mt76x8.mk
parent8c64824576598117958691853de68bf4dcfc3c06 (diff)
downloadupstream-f1c193c27e714a051b49788fff3aecbd728190e1.tar.gz
upstream-f1c193c27e714a051b49788fff3aecbd728190e1.tar.bz2
upstream-f1c193c27e714a051b49788fff3aecbd728190e1.zip
ramips: add support for ALFA Network AWUSFREE1
ALFA Network AWUSFREE1 is an USB Wi-Fi N300 adapter based on MT7628. Specification: - MT7628AN (580 MHz) - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 2T2R 2.4 GHz (MT7628) with external FEM (RFFM4203) - 2x detachable antennas (RP-SMA) - ASIX AX88772 USB to Ethernet bridge (connected with MT7628 PHY0) - 4x LED (2 driven by GPIO) - 1x button (reset) - 1x mini USB for host and main power input - UART header on PCB Flash instruction: You can use sysupgrade image directly in vendor firmware which is based on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot: 1. Power device with reset button pressed and release it after ~5 sec. 2. Setup static IP 192.168.1.2/4 on your PC. 3. Go to 192.168.1.1 in browser and upload "sysupgrade" image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 415075b22d..bcee98ef45 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -19,6 +19,15 @@ endef
DEVICE_VARS += TPLINK_FLASHLAYOUT TPLINK_HWID TPLINK_HWREV TPLINK_HWREVADD TPLINK_HVERSION
+define Device/alfa-network_awusfree1
+ DTS := AWUSFREE1
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := ALFA Network AWUSFREE1
+ DEVICE_PACKAGES := uboot-envtools
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+endef
+TARGET_DEVICES += alfa-network_awusfree1
+
define Device/tama_w06
DTS := W06
IMAGE_SIZE := 15040k