aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorPeter Lundkvist <peter.lundkvist@gmail.com>2018-03-17 18:47:51 +0100
committerMathias Kresin <dev@kresin.me>2018-03-18 22:22:38 +0100
commitd13b05741a4d05a271d26fc3be61e76530025098 (patch)
treefe804b278be33f45ff11b7994ece4d846a1e2423 /target/linux/ramips/image/mt76x8.mk
parenta5bd8de0bd80b83e43ce90ddc6623890344ad33d (diff)
downloadupstream-d13b05741a4d05a271d26fc3be61e76530025098.tar.gz
upstream-d13b05741a4d05a271d26fc3be61e76530025098.tar.bz2
upstream-d13b05741a4d05a271d26fc3be61e76530025098.zip
ramips: add support for TP-Link TL-WR902AC v3
TP-Link TL-WR902AC v3 is a pocket-size dual-band (AC750) router based on MediaTek MT7628N + MT7650E. Specification: - MediaTek MT7628N/N (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz and 1T1R 5 GHz - 1x 10/100 Mbps Ethernet * MT7650 ac chip isn't not supported by LEDE/OpenWrt at the moment. Therefore 5Ghz won' work. Flash instruction: The only way to flash LEDE image in TL-WR902AC v3 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "openwrt-ramips-mt76x8-tplink_tl-wr902ac-v3-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with the LAN port, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Peter Lundkvist <peter.lundkvist@gmail.com> [drop p2led_an pinmux, this pin isn't used as gpio, fix whitespace issues] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index bcee98ef45..4362c3bc43 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -196,6 +196,21 @@ define Device/tplink_tl-mr3420-v5
endef
TARGET_DEVICES += tplink_tl-mr3420-v5
+define Device/tplink_tl-wr902ac-v3
+ $(Device/tplink)
+ DTS := TL-WR902ACV3
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-WR902AC v3
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x000dc88f
+ TPLINK_HWREV := 0x89
+ TPLINK_HWREVADD := 0x1
+ TPLINK_HVERSION := 3
+ IMAGES += factory.bin
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-wr902ac-v3
+
define Device/u7628-01-128M-16M
DTS := U7628-01-128M-16M
IMAGE_SIZE := 16064k