aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2017-11-08 14:00:06 +0100
committerMathias Kresin <dev@kresin.me>2017-11-08 23:25:05 +0100
commitd0ef27594a8d9156e6748e890229d2daa32465fd (patch)
treeb3e9318a0bda2efc5efea2913701556a63c102c5 /target/linux/ramips/image/mt76x8.mk
parent73c745f64f17a0326c53e614aa0dd125b47053ec (diff)
downloadupstream-d0ef27594a8d9156e6748e890229d2daa32465fd.tar.gz
upstream-d0ef27594a8d9156e6748e890229d2daa32465fd.tar.bz2
upstream-d0ef27594a8d9156e6748e890229d2daa32465fd.zip
ramips: add support for TP-Link TL-WR840N v5
TP-Link TL-WR840N v5 is simple N300 router with 5-port FE switch and non-detachable antennas, based on MediaTek MT7628NN (aka MT7628N) WiSoC. Specification: - MT7628N/N (580 MHz) - 64 MB of RAM (DDR2) - 4 MB of FLASH - 2T2R 2.4 GHz - 5x 10/100 Mbps Ethernet - 2x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - 1x LED (GPIO-controlled), 1x button * LED in TL-WR840N v5 is a dual-color, dual-leads type which isn't (fully) supported by gpio-leds driver. This type of LED requires both GPIOs state change at the same time to select color or turn it off. For now, we support/use only the green part of the LED. Orange LED is registered so you can later use it for your own purposes. Flash instruction: Unlike TL-WR840N v4 flashing through WEB UI works in v5. 1. Download lede-ramips-mt76x8-tl-wr840n-v5-squashfs-sysupgrade.bin image. 2. Go to 192.168.0.1 3. Flash the sysupgrade image through Firmware upgrade section of WEB UI. 4. Wait until green LED stops flashing and use the router. Notes: TFTP recovery is broken since TP-Link reused bootloader code for v4 and that does not take into account only 4 MB of flash and bricks the device. So do not use TFTP Recovery or you will have to rewrite SPI flash. They fixed it in later GPL code,but it is unknown which version of bootloader you have. After manually compiling and flashing bootloader from GPL sources TFTP recovery works properly. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 56da7b1049..248f45eebd 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -99,6 +99,21 @@ define Device/tl-wr840n-v4
check-size $$$$(IMAGE_SIZE)
endef
+define Device/tl-wr840n-v5
+ DTS := TL-WR840NV5
+ IMAGE_SIZE := 3840k
+ DEVICE_TITLE := TP-Link TL-WR840N v5
+ TPLINK_FLASHLAYOUT := 4Mmtk
+ TPLINK_HWID := 0x08400005
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ KERNEL := $(KERNEL_DTB)
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
+ IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
+ check-size $$$$(IMAGE_SIZE)
+endef
+
define Device/tl-wr841n-v13
$(Device/tl-wr840n-v4)
DTS := TL-WR841NV13
@@ -107,7 +122,7 @@ define Device/tl-wr841n-v13
TPLINK_HWREV := 0x268
TPLINK_HWREVADD := 0x13
endef
-TARGET_DEVICES += tl-wr840n-v4 tl-wr841n-v13
+TARGET_DEVICES += tl-wr840n-v4 tl-wr840n-v5 tl-wr841n-v13
define Device/vocore2
DTS := VOCORE2