aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorRomain MARIADASSOU <roms2000@free.fr>2018-06-27 01:24:39 +0200
committerMathias Kresin <dev@kresin.me>2018-07-04 01:20:02 +0200
commitce31bdc20c3f2eb387a84c277dff76324a8e39c7 (patch)
tree611514e62b7664ebe3fd9ee94f9b776312bb9828 /target/linux/ramips/image/mt76x8.mk
parent7d07bc96b7e686244ed096d3bbfad297a2ec1ce9 (diff)
downloadupstream-ce31bdc20c3f2eb387a84c277dff76324a8e39c7.tar.gz
upstream-ce31bdc20c3f2eb387a84c277dff76324a8e39c7.tar.bz2
upstream-ce31bdc20c3f2eb387a84c277dff76324a8e39c7.zip
ramips: add support for TL-WA801ND v5
Specification: - System-On-Chip: MediaTek MT7628NN - CPU/Speed: 580 MHz - Flash-Chip: ELM Technology GD25Q64 - Flash size: 8192 KiB - RAM: 64 MiB - Wireless No1: SoC-integrated: MT7628N 2.4GHz 802.11bgn Currently the only method to install openwrt for the first time is via TFTP recovery. After first install you can use regular updates. Flash instructions: 1) To flash the recovery image, start a TFTP server with IP address 192.168.0.66 and serve the recovery image named tp_recovery.bin. 2) Connect your device to the LAN port, then press the WPS and Reset button and power it up. Keep pressing the WPS/Reset button for 10 seconds or until the lock LED is lighting up. It will try to download the recovery image and flash it. It can take up to 2-3 minutes to finish. When it reaches 100%, the router will reboot itself. Signed-off-by: Romain MARIADASSOU <roms2000@free.fr>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 6c75002a84..eaafb149a2 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -114,6 +114,19 @@ define Device/pbr-d1
endef
TARGET_DEVICES += pbr-d1
+define Device/tplink_tl-wa801nd-v5
+ $(Device/tplink)
+ DTS := TL-WA801NDV5
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-WA801ND v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x08010005
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+endef
+TARGET_DEVICES += tplink_tl-wa801nd-v5
+
define Device/tl-wr840n-v4
$(Device/tplink)
DTS := TL-WR840NV4