aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-10-09 13:51:21 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-10-09 17:34:41 +0200
commitb73986a8264016883a8a7d666687a340cb810934 (patch)
treeb9cbed05e2a9793a27a74905d271e8f0ffb4dd97 /target/linux/ramips/image/mt76x8.mk
parent49b84624eb694ed8238472db758708384fe62ce6 (diff)
downloadupstream-b73986a8264016883a8a7d666687a340cb810934.tar.gz
upstream-b73986a8264016883a8a7d666687a340cb810934.tar.bz2
upstream-b73986a8264016883a8a7d666687a340cb810934.zip
ramips/mt76x8: add initramfs support for tplink 841n v13
The tplink 841n v13 requires an tplink v2 image header in front of an initramfs image. To boot an initramfs image: - break the uboot by holding the '4' key - setup your tftp server 192.168.0.255 - tftp 81000000 lede-ramips-mt76x8-tl-wr841n-v13-initramfs-kernel.bin - bootm Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index db32684f7d..56da7b1049 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -91,6 +91,7 @@ define Device/tl-wr840n-v4
TPLINK_HWREVADD := 0x4
TPLINK_HVERSION := 3
KERNEL := $(KERNEL_DTB)
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
IMAGES += tftp-recovery.bin
IMAGE/factory.bin := tplink-v2-image -e
IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)