aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-01-17 08:14:41 +0100
committerMathias Kresin <dev@kresin.me>2018-01-23 23:31:09 +0100
commita411881a4000452ff791761c8f1d37ea6faa298a (patch)
tree4586487810d420d1fb657f62446f517975efe32b /target/linux/ramips/image/mt76x8.mk
parent6f425a28a4147c52f990ead5336b75551a551aeb (diff)
downloadupstream-a411881a4000452ff791761c8f1d37ea6faa298a.tar.gz
upstream-a411881a4000452ff791761c8f1d37ea6faa298a.tar.bz2
upstream-a411881a4000452ff791761c8f1d37ea6faa298a.zip
ramips: add flash size postfix to Widora neo
Rename the Widora neo by adding a flash size prefix. Move the common parts into a dtsi to be prepare everything for upcomming support of the 32MB version. Migrate the Widora neo to the generic board detection as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index ae8a1344d5..6c0102fc92 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -215,13 +215,14 @@ define Device/wl-wn575a3
endef
TARGET_DEVICES += wl-wn575a3
-define Device/widora-neo
- DTS := WIDORA-NEO
+define Device/widora_neo-16m
+ DTS := WIDORA-NEO-16M
IMAGE_SIZE := $(ralink_default_fw_size_16M)
- DEVICE_TITLE := Widora-NEO
+ DEVICE_TITLE := Widora-NEO (16M)
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ SUPPORTED_DEVICES += widora-neo
endef
-TARGET_DEVICES += widora-neo
+TARGET_DEVICES += widora_neo-16m
define Device/wrtnode2p
DTS := WRTNODE2P