aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2018-05-30 18:41:53 +0300
committerMathias Kresin <dev@kresin.me>2018-06-16 10:08:51 +0200
commit8956eb502df2d3e40a1c83a46d2781e732f08910 (patch)
tree0417ca5cad861306a2bb03f12fcc17098f619274 /target/linux/ramips/image/mt76x8.mk
parent82fa7b9d78acf53708ee6480df328b11023e4a56 (diff)
downloadupstream-8956eb502df2d3e40a1c83a46d2781e732f08910.tar.gz
upstream-8956eb502df2d3e40a1c83a46d2781e732f08910.tar.bz2
upstream-8956eb502df2d3e40a1c83a46d2781e732f08910.zip
ramips: add support for TP-Link TL-WR842N v5
TP-Link TL-WR842N v5 are simple N300 router with 5-port FE switch and non-detachable antennas. Its very similar to TP-Link TL-MR3420 V5. Specification: - MT7628N/N (580 MHz) - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz - 5x 10/100 Mbps Ethernet - 2x external, non-detachable antennas - USB 2.0 Port - UART (J1) header on PCB (115200 8n1) - 7x LED, 2x button, power input switch Flash instruction: The only way to flash OpenWrt image in wr842nv5 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.225/24 and tftp server. 2. Rename "lede-ramips-mt7628-tplink_tl-wr842n-v5-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index aeb6faf0e7..443e1c79ab 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -196,6 +196,20 @@ define Device/tplink_tl-mr3420-v5
endef
TARGET_DEVICES += tplink_tl-mr3420-v5
+define Device/tplink_tl-wr842n-v5
+ $(Device/tplink)
+ DTS := TL-WR842NV5
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-WR842N v5
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x08420005
+ TPLINK_HWREV := 0x5
+ TPLINK_HWREVADD := 0x5
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-wr842n-v5
+
define Device/tplink_tl-wr902ac-v3
$(Device/tplink)
DTS := TL-WR902ACV3