aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2018-01-09 14:25:53 +0300
committerMathias Kresin <dev@kresin.me>2018-01-15 21:45:43 +0100
commit5bdd238b634a34b038fbea9046893de29a77c000 (patch)
treebe539d819e8fc80905b6574132ceebd081b9fb56 /target/linux/ramips/image/mt76x8.mk
parentff1e89553078cb1f8851276537d1267930d740df (diff)
downloadupstream-5bdd238b634a34b038fbea9046893de29a77c000.tar.gz
upstream-5bdd238b634a34b038fbea9046893de29a77c000.tar.bz2
upstream-5bdd238b634a34b038fbea9046893de29a77c000.zip
ramips: add support for TP-Link Archer C20 v4
TP-Link Archer C20 v4 is a router with 5-port FE switch and non-detachable antennas. It's based on MediaTek MT7628N+MT7610EN. Specification: - MediaTek MT7628N/N (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz and 1T1R 5 GHz - 5x 10/100 Mbps Ethernet - 3x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - 7x LED (GPIO-controlled*), 2x button, power input switch * WAN LED in this devices is a dual-color, dual-leads type which isn't (fully) supported by gpio-leds driver. This type of LED requires both GPIOs state change at the same time to select color or turn it off. For now, we support/use only the green part of the LED. * MT7610EN ac chip isn't not supported by LEDE. Therefore 5Ghz won't work. Flash instruction: The only way to flash LEDE image in ArcherC20v4 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "openwrt-ramips-mt7628-ArcherC20v4-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 8bbbcf6ad9..60864cfed3 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -139,6 +139,19 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_c20-v4
+ $(Device/tplink)
+ DTS := ArcherC20v4
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link ArcherC20 v4
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0xc200004
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x4
+ TPLINK_HVERSION := 3
+endef
+TARGET_DEVICES += tplink_c20-v4
+
define Device/tplink_tl-mr3420-v5
$(Device/tplink)
DTS := TL-MR3420V5