aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorJackson Ming Hu <huming2207@gmail.com>2018-01-08 13:27:28 +0800
committerMathias Kresin <dev@kresin.me>2018-01-23 23:31:09 +0100
commit21d3643828187df873118c4c2a51a48c54e0f6b1 (patch)
tree0fa594679b0a143c9fc36501fea32a47c7ec7d73 /target/linux/ramips/image/mt76x8.mk
parenta411881a4000452ff791761c8f1d37ea6faa298a (diff)
downloadupstream-21d3643828187df873118c4c2a51a48c54e0f6b1.tar.gz
upstream-21d3643828187df873118c4c2a51a48c54e0f6b1.tar.bz2
upstream-21d3643828187df873118c4c2a51a48c54e0f6b1.zip
ramips: add support for Widora Neo 32MB flash revision
Widora has updated their Widora Neo board recently. The new model uses 32MB WSON-8 factor SPI flash instead of the original 16MB SOP-8 factor SPI flash. All the other hardware components are the same as the first revision. Detailed hardware specs listed below: CPU: MTK MT7688AN RAM: 128MB DDR2 ROM: 32MB WSON-8 factor SPI Flash (Winbond) WiFi: Built-in 802.11n 150Mbps? Ethernet: 10/100Mbps x1 Audio codec: WM8960 Other IO: USB OTG; USB Power+Serial (CP2104); 3x LEDs (Power, LAN, WiFi); 2x Keys (WPS, CPU Reset) 1x Audio In/Out 1x IPEX antenna port 1x Micro SD slot Signed-off-by: Jackson Ming Hu <huming2207@gmail.com> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 6c0102fc92..f58a2208c1 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -224,6 +224,14 @@ define Device/widora_neo-16m
endef
TARGET_DEVICES += widora_neo-16m
+define Device/widora_neo-32m
+ DTS := WIDORA-NEO-32M
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := Widora-NEO (32M)
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += widora_neo-32m
+
define Device/wrtnode2p
DTS := WRTNODE2P
IMAGE_SIZE := $(ralink_default_fw_size_16M)