aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-22 14:06:14 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-11 01:30:11 +0200
commitf4eef5f2a18400bc7f548d629e1d5825a2b26e5a (patch)
tree121b4c19363931e1b065995e74a58e71bf5e3bc8 /target/linux/ramips/image/mt7621.mk
parent26a6a6a60ba74875b5ef819ac5765d3bcbbb930e (diff)
downloadupstream-f4eef5f2a18400bc7f548d629e1d5825a2b26e5a.tar.gz
upstream-f4eef5f2a18400bc7f548d629e1d5825a2b26e5a.tar.bz2
upstream-f4eef5f2a18400bc7f548d629e1d5825a2b26e5a.zip
ramips: add support for Linksys E7350
Linksys E7350 is an 802.11ax (Wi-Fi 6) router, based on MediaTek MT7621A. Specifications: - SoC: MT7621 (880MHz, 2 Cores) - RAM: 256 MB - Flash: 128 MB NAND - Wi-Fi: - MT7915D: 2.4/5 GHz (DBDC) - Ethernet: 5x 1GiE MT7530 - USB: 1x USB 3.0 - UART: J4 (57600 baud) - Pinout: [3V3] (TXD) (RXD) (blank) (GND) Notes: * This device has a dual-boot partition scheme, but this firmware works only on boot partition 1. Installation: Upload the generated factory.bin image via the stock web firmware updater. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 974299f26b..661f44d5e9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1192,6 +1192,15 @@ define Device/linksys_e5600
endef
TARGET_DEVICES += linksys_e5600
+define Device/linksys_e7350
+ $(Device/belkin_rt1800)
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := E7350
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+ append-ubi | check-size | belkin-header GOLF 1 9.9.9
+endef
+TARGET_DEVICES += linksys_e7350
+
define Device/linksys_ea7xxx
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)