aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorTamas Balogh <tamasbalogh@hotmail.com>2022-06-20 11:02:15 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-29 00:57:56 +0200
commit74dd7f9c36cbe4b87bfdfa0d55729d29d148be16 (patch)
tree90086952d49f4012df22857d2de0aa478bf1ce75 /target/linux/ramips/image/mt7621.mk
parent35fec487e30f05c81bd135326a993dad7f861812 (diff)
downloadupstream-74dd7f9c36cbe4b87bfdfa0d55729d29d148be16.tar.gz
upstream-74dd7f9c36cbe4b87bfdfa0d55729d29d148be16.tar.bz2
upstream-74dd7f9c36cbe4b87bfdfa0d55729d29d148be16.zip
ramips: add support for ASUS RP-AC87
Asus RP-AC87 ac2600 Repeater 2.4GHz 800Mbps 5GHz 1733Mbps Hardware specifications: SoC: MT7621A 2 cores 4 threads @880MHz WiFi2G: MT7615E 2G 4x4 b/g/n Wifi5G: MT7615E 5G 4x4 n/ac DRAM: 128MB DDR3 @1200mhz Flash: 16MB MX25L12805D SPI-NOR LAN/WAN: MT7530 1x1000M MAC addresses as verified by OEM firmware: use address source Lan/W5G *:B0 factory 0x8004 (label) W2G *:B4 factory 0x0 Installation: Asus windows recovery tool: install the Asus firmware restoration utility unplug the router, hold the reset button while powering it on release when the power LED flashes slowly specify a static IP on your computer: IP address: 192.168.1.75 Subnet mask 255.255.255.0 Start the Asus firmware restoration utility, specify the factory image and press upload Do not power off the device after OpenWrt has booted until the LED flashing. TFTP Recovery method: set computer to a static ip, 192.168.1.2 connect computer to the LAN 1 port of the router hold the reset button while powering on the router for a few seconds send firmware image using a tftp client; i.e from linux: $ tftp tftp> binary tftp> connect 192.168.1.1 tftp> put factory.bin tftp> quit Signed-off-by: Tamas Balogh <tamasbalogh@hotmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b2b6f6b4cd..aa7adeee60 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -175,6 +175,20 @@ define Device/asiarf_ap7621-nv1
endef
TARGET_DEVICES += asiarf_ap7621-nv1
+define Device/asus_rp-ac87
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RP-AC87
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | pad-rootfs | check-size
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware rssileds
+endef
+TARGET_DEVICES += asus_rp-ac87
+
define Device/asus_rt-ac57u
$(Device/dsa-migration)
DEVICE_VENDOR := ASUS