aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-14 02:06:40 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-21 04:28:52 +0100
commit3c6692ba03b0d1a755d4cd4881479c89ba4e41ca (patch)
tree9143fbf74a606bdb97d3149268328654f87c783f /target/linux/ramips/image/mt7621.mk
parenta507243bfeb1597bb78a5e5e8101022e6aca0836 (diff)
downloadupstream-3c6692ba03b0d1a755d4cd4881479c89ba4e41ca.tar.gz
upstream-3c6692ba03b0d1a755d4cd4881479c89ba4e41ca.tar.bz2
upstream-3c6692ba03b0d1a755d4cd4881479c89ba4e41ca.zip
ramips: add support for TP-Link Archer AX23 v1
Hardware -------- CPU: MediaTek MT7621 DAT RAM: 128MB DDR3 (integrated) FLASH: 16MB SPI-NOR () WiFi: MediaTek MT7905 + MT7975 (2.4 / 5 DBDC) 802.11ax SERIAL: 115200 8N1 LEDs - (3V3 - GND - RX - TX) - ETH ports Installation ------------ Upload the factory image using the Web-UI. Web-Recovery ------------ The router supports a HTTP recovery mode by holding the reset-button when powering on. The interface is reachable at 192.168.0.1 and supports installation using the factory image. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4)
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 961f8a3b75..11a1e4cb6a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1631,6 +1631,18 @@ define Device/totolink_x5000r
endef
TARGET_DEVICES += totolink_x5000r
+define Device/tplink_archer-ax23-v1
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := Archer AX23
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7915e -uboot-envtools
+ TPLINK_BOARD_ID := ARCHER-AX23-V1
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += tplink_archer-ax23-v1
+
define Device/tplink_archer-a6-v3
$(Device/dsa-migration)
$(Device/tplink-safeloader)