aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDale Hui <strokes-races0b@icloud.com>2021-08-20 22:36:50 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 15:15:30 +0200
commitaf3104d25b0b254d54b3bb3cc570c958c24c4015 (patch)
tree11e4ba578f589a32c7ac19187b63b49c0a1cf774 /target/linux/ramips/image/mt7621.mk
parentfc050c7b53116b6e3f2c31797b27cfc76af60e74 (diff)
downloadupstream-af3104d25b0b254d54b3bb3cc570c958c24c4015.tar.gz
upstream-af3104d25b0b254d54b3bb3cc570c958c24c4015.tar.bz2
upstream-af3104d25b0b254d54b3bb3cc570c958c24c4015.zip
ramips: make Netgear R7200 a separate device from R6700v2
With the various variants of Netgear R**** devices, make it more obvious which image should be used for the R7200. Signed-off-by: Dale Hui <strokes-races0b@icloud.com> [provide proper commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 12 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 68993a02fb..cab926dccd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1065,9 +1065,6 @@ define Device/netgear_r6700-v2
DEVICE_ALT0_VENDOR := NETGEAR
DEVICE_ALT0_MODEL := Nighthawk AC2400
DEVICE_ALT0_VARIANT := v1
- DEVICE_ALT1_VENDOR := NETGEAR
- DEVICE_ALT1_MODEL := R7200
- DEVICE_ALT1_VARIANT := v1
SERCOMM_HWNAME := R6950
SERCOMM_HWID := BZV
SERCOMM_HWVER := A001
@@ -1101,6 +1098,18 @@ define Device/netgear_r6850
endef
TARGET_DEVICES += netgear_r6850
+define Device/netgear_r7200
+ $(Device/netgear_sercomm_nand)
+ DEVICE_MODEL := R7200
+ SERCOMM_HWNAME := R6950
+ SERCOMM_HWID := BZV
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x1032
+ IMAGE_SIZE := 40960k
+ DEVICE_PACKAGES += kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += netgear_r7200
+
define Device/netgear_wac104
$(Device/netgear_sercomm_nand)
DEVICE_MODEL := WAC104