aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorYuchan Seo <hexagonwin@disroot.org>2021-10-12 21:04:44 -0400
committerSungbo Eo <mans0n@gorani.run>2021-12-04 09:39:11 +0900
commitc33eb0372e7cbc404eb77a811bca7fe1eed8a2a9 (patch)
tree21d039c107c950e9aa68938eb833b01bd4ec44d0 /target/linux/ramips/image/mt7621.mk
parent3843c641d83b621e07f03753a5617ab27e55e262 (diff)
downloadupstream-c33eb0372e7cbc404eb77a811bca7fe1eed8a2a9.tar.gz
upstream-c33eb0372e7cbc404eb77a811bca7fe1eed8a2a9.tar.bz2
upstream-c33eb0372e7cbc404eb77a811bca7fe1eed8a2a9.zip
ramips: add support for ipTIME A3004NS-dual
ipTIME A3004NS-dual is a 2.4/5GHz band router, based on Mediatek MT7621. Specifications: - SoC: MT7621 (880MHz) - RAM: DDR3 256M - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: MT7602E - 5GHz : MT7612E - Ethernet: - 4x LAN - 1x WAN - USB: 1 * USB3.0 port - UART: - 3.3V, TX, RX, GND / 57600 8N1 Installation via web interface: - 1. Flash Initramfs image using OEM Firmware's web GUI - 2. Boot into OpenWrt and perform Sysupgrade with sysupgrade image. Revert to stock firmware: - 1. Boot into OpenWrt and perform Sysupgrade with OEM Stock Firmware image. Signed-off-by: Yuchan Seo <hexagonwin@disroot.org> Reviewed-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 3b68a76b3e..2b08efc468 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -736,6 +736,17 @@ define Device/iodata_wnpr2600g
endef
TARGET_DEVICES += iodata_wnpr2600g
+define Device/iptime_a3004ns-dual
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16128k
+ UIMAGE_NAME := a3004nd
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A3004NS-dual
+ DEVICE_PACKAGES := kmod-usb3 kmod-mt76x2 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += iptime_a3004ns-dual
+
define Device/iptime_a6ns-m
$(Device/dsa-migration)
IMAGE_SIZE := 16128k