aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:27 +0200
commit363197311b342a59b3c67e4bd2dfea3b3030b456 (patch)
tree011d1f66850ea187a3e74f3badec2d108e705234 /target/linux/ramips/image/mt7621.mk
parent24ded1810b071ec7e7c8d134e5491d9649c13dac (diff)
downloadupstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.gz
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.bz2
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.zip
ramips: remove default IMAGE_SIZE for ramips target
Currently, ramips target defines 0x7b0000 as default IMAGE_SIZE for all devices in ramips target, i.e. this will be set if a device does not specify IMAGE_SIZE itself. From 92 devices using that default due to a "missing" IMAGE_SIZE, 14 were incorrect by a small amount (i.e. still "8M" flash) and 12 were completely off ("16M", "4M", ...). This patch thus removes the _default_ IMAGE_SIZE and defines IMAGE_SIZE for each device individually. This should indicate to people supporting new devices that this parameter has to be cared about. For the present code, this patch is cosmetical. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e604302954..bb55fc34da 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -295,6 +295,7 @@ TARGET_DEVICES += lenovo_newifi-d1
define Device/linksys_re6500
MTK_SOC := mt7621
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
DEVICE_VENDOR := Linksys
DEVICE_MODEL := RE6500
DEVICE_PACKAGES := kmod-mt76x2 wpad-basic
@@ -497,6 +498,7 @@ TARGET_DEVICES += samknows_whitebox-v8
define Device/storylink_sap-g3200u3
MTK_SOC := mt7621
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
DEVICE_VENDOR := STORYLiNK
DEVICE_MODEL := SAP-G3200U3
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic