aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-10 14:16:23 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-11 18:38:42 +0200
commit479adb0929f8afbd1935a0d71832df1e2cea18b2 (patch)
tree626aed63cb69592d5851c7daaeccebd25f544b91 /target/linux/ramips/image/mt7621.mk
parent9faf9f8f23f43300bfb892abe6513ead30374e20 (diff)
downloadupstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.tar.gz
upstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.tar.bz2
upstream-479adb0929f8afbd1935a0d71832df1e2cea18b2.zip
ramips: consolidate recipes with uimage_padhdr
There are already two very similar recipes using uimage_padhdr in ramips target, and a third one is about to be added. Make the recipe more generic, so redefinitions are not necessary anymore. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Bjørn Mork <bjorn@mork.no> [Zyxel WAP6805]
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0215683671..25de2fa597 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -81,11 +81,6 @@ define Build/iodata-mstc-header
)
endef
-define Build/mitrastarimage
- uimage_padhdr -l 160 -i $@ -o $@.new
- mv $@.new $@
-endef
-
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:7' > $(1).compat; \
@@ -1146,7 +1141,7 @@ define Device/zyxel_wap6805
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := WAP6805
DEVICE_PACKAGES := kmod-mt7603 wpad-basic kmod-mt7621-qtn-rgmii
- KERNEL := $(KERNEL_DTB) | uImage lzma | mitrastarimage
+ KERNEL := $(KERNEL_DTB) | uImage lzma | uimage-padhdr 160
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
TARGET_DEVICES += zyxel_wap6805