aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorBirger Koblitz <mail@birger-koblitz.de>2019-09-15 16:20:11 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-20 11:36:27 +0200
commitfde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4 (patch)
treee67d2fdabc8434dc8d2100236f6b249afc1dc14d /target/linux/ramips/image/mt7621.mk
parentf285e8634c57d28aa970b80c5c59e85485f35c7d (diff)
downloadupstream-fde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4.tar.gz
upstream-fde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4.tar.bz2
upstream-fde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4.zip
ramips: add support for Asus RT-AC85P
SoC: MediaTek MT7621AT dual-core @ 880MHz RAM: 256M (Winbond W632GG6KB-1) FLASH: 128MB (Macronix MX30LF1G18AC-TI) WiFi: - 2.4GHz MediaTek MT7615N bgn - 5GHz MediaTek MT7615N nac Switch: SoC integrated Gigabit Switch (4 x LAN, 1 x WAN) USB: 1 x USB 3.1 (Gen 1) BTN: Reset, WPS LED: - Power (blue) - 5Ghz (blue) - 2.4GHz (blue) - Internet (blue) - 4x LAN (blue) (LAN/WAN leds are not controllable by GPIOs) UART: UART is present as Pads marked J4 on the PCB. 3.3V - TX - RX - GND / 57600-8N1 3.3V is the square pad MAC: The MAC address on the router-label matches the MAC of the 2.4 GHz WiFi. LAN and WAN MAC are identical: MAC_LABEL+4 5 GHz WiFi MAC: also MAC_LABEL+4 Installation ------------ Via U-Boot tftpd: Switch on device, within 2s press reset button and keep pressed until power LED starts blinking slowly. Upload factory image via tftp put, the router's ip is 192.168.1.1 and expects the client on 192.168.1.75. The images also work on the Asus RT-AC65P models as tested by Gabor. Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Tested-by: Gabor Varga <vargagab@gmail.com> [fixed Asus -> ASUS in DTS] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 623d5c94dd..1727f998c8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -134,6 +134,22 @@ define Device/asus_rt-ac57u
endef
TARGET_DEVICES += asus_rt-ac57u
+define Device/asus_rt-ac85p
+ MTK_SOC := mt7621
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-AC85P
+ IMAGE_SIZE := 51200k
+ UBINIZE_OPTS := -E 5
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-usb3 kmod-mt7615e wpad-basic uboot-envtools
+endef
+TARGET_DEVICES += asus_rt-ac85p
+
define Device/buffalo_wsr-1166dhp
MTK_SOC := mt7621
IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata