aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorZhenjian Zhang <itdesk.zhang@gmail.com>2019-08-13 14:30:29 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-08-24 08:55:33 +0800
commitfb3574f1238cd958554d0b77f157f15508247dae (patch)
tree0dde1b4cf4bc23f85845bbb0c972adea81ccca52 /target/linux/ramips/image/mt7621.mk
parent4346de8d34b541bb6b2eb7025119aeb150e4dab8 (diff)
downloadupstream-fb3574f1238cd958554d0b77f157f15508247dae.tar.gz
upstream-fb3574f1238cd958554d0b77f157f15508247dae.tar.bz2
upstream-fb3574f1238cd958554d0b77f157f15508247dae.zip
ramips: add support for ADSLR G7
SoC: MT7621AT RAM: 256MB Flash: 16M SPI Ethernet: 5x GE ports WiFi: 2.4G: MT7615N 5G: MT7615N Flash instruction: 1.Modify the file to linux.bin 2.Set up FTP service 3.Computer settings fixed IP: 192.168.179.50 255.255.255.0 4.Turn on the power and press and hold the reset button until the indicator light is on for about 5 seconds. Signed-off-by: Zhenjian Zhang <itdesk.zhang@gmail.com> [fix mac location] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d32feb7eab..5dc8efe7c5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -535,6 +535,15 @@ define Device/totolink_a7000r
endef
TARGET_DEVICES += totolink_a7000r
+define Device/adslr_g7
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ADSLR
+ DEVICE_MODEL := G7
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += adslr_g7
+
define Device/tplink-safeloader
MTK_SOC := mt7621
DEVICE_VENDOR := TP-Link