aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorBirger Koblitz <mail@birger-koblitz.de>2019-09-19 21:33:59 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-20 11:36:27 +0200
commitf285e8634c57d28aa970b80c5c59e85485f35c7d (patch)
tree6f484b810e10084a6a1fff8c3a2ce6fff772c722 /target/linux/ramips/image/mt7621.mk
parent2e2fe82d1e74794a2fe78861ed43627798d5ae4b (diff)
downloadupstream-f285e8634c57d28aa970b80c5c59e85485f35c7d.tar.gz
upstream-f285e8634c57d28aa970b80c5c59e85485f35c7d.tar.bz2
upstream-f285e8634c57d28aa970b80c5c59e85485f35c7d.zip
ramips: add support for Edimax RG21S
SoC: MediaTek MT7621AT dual-core @ 880MHz RAM: 256M (Nanya NT5CC128M) FLASH: 16MB (Macronix MX25L12835F) WiFi: - 2.4GHz MediaTek MT7615N bgn - 5GHz MediaTek MT7615N nac Switch: SoC integrated Gigabit Switch (4 x LAN, 1 x WAN) USB: No BTN: Reset, WPS LED: 4 red LEDs, indistinguishable when casing closed UART: UART is present as Pads marked J1 on the PCB. 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation ------------ Update the factory image via the OEM web-interface (by default:http://192.168.1.1) The sysupgrade image can be installed via TFTP from the U-Boot bootloader. Connect ethernet port 2. Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> [flash node rename, EDIMAX -> Edimax, complete device model name] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 986fe5e2f8..623d5c94dd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -30,6 +30,25 @@ define Build/elecom-wrc-factory
mv $@.new $@
endef
+define Build/elx-header
+ $(eval hw_id=$(word 1,$(1)))
+ $(eval xor_pattern=$(word 2,$(1)))
+ ( \
+ echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
+ dd bs=42 count=1 conv=sync; \
+ hw_id="$(hw_id)"; \
+ echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
+ dd bs=20 count=1 conv=sync; \
+ echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+ dd bs=8 count=1 conv=sync; \
+ echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+ dd bs=58 count=1 conv=sync; \
+ ) > $(KDIR)/tmp/$(DEVICE_NAME).header
+ $(call Build/xor-image,-p $(xor_pattern) -x)
+ cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
+ mv $@.new $@
+endef
+
define Build/iodata-factory
$(eval fw_size=$(word 1,$(1)))
$(eval fw_type=$(word 2,$(1)))
@@ -173,6 +192,20 @@ define Device/d-team_pbr-m1
endef
TARGET_DEVICES += d-team_pbr-m1
+define Device/edimax_rg21s
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Edimax
+ DEVICE_MODEL := Gemini AC2600 RG21S
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ elx-header 02020038 8844A2D168B45A2D
+ DEVICE_PACKAGES := \
+ kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += edimax_rg21s
+
define Device/elecom_wrc-1167ghbk2-s
MTK_SOC := mt7621
IMAGE_SIZE := 15488k