aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorZengFei Zhang <zhangzengfei@kunteng.org>2017-02-22 20:47:22 +0800
committerMathias Kresin <dev@kresin.me>2017-02-28 23:46:02 +0100
commitedae3479e64e93275dce4a928ea70279282eef9d (patch)
tree3a9e78e098b52d4e6e66c5edb636e6b8a0390f6e /target/linux/ramips/image/mt7621.mk
parent2677b66f9ba31dccbf3c815776fb6125fd9bfed3 (diff)
downloadupstream-edae3479e64e93275dce4a928ea70279282eef9d.tar.gz
upstream-edae3479e64e93275dce4a928ea70279282eef9d.tar.bz2
upstream-edae3479e64e93275dce4a928ea70279282eef9d.zip
ramips: add support for HiWiFi HC5962
This patch adds supports for the HiWiFi HC5962(gee4) http://www.hiwifi.com Short specification: - MT7621AT + MT7612EN + 7603EN - 256MB DDR3 RAM - 128MB NAND flash - 1+3 x 1000M Ethernet - 1x USB 2.0 port. 1x USB 3.0 port. - reset button - UART pad on PCB (JP3: TX, RX, GND, 3.3V) Flash instruction: 1, Download lede-ramips-mt7621-hc5962-squashfs-factory.bin 2, Login as root via SSH on 192.168.199.1 and then copy factory.bin(using wget or nc or...) to /tmp/ 3, use the following commands: $ mtd write /tmp/lede-ramips-mt7621-hc5962-squashfs-factory.bin firmware $ mtd erase firmware_backup && reboot After reboot you should be able to login as root via SSH on 192.168.1.1 Signed-off-by: ZengFei Zhang <zhangzengfei@kunteng.org>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 83c9d6d8f1..d40c185084 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -71,6 +71,21 @@ define Device/firewrt
endef
TARGET_DEVICES += firewrt
+define Device/hc5962
+ DTS := HC5962
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 2097152
+ UBINIZE_OPTS := -E 5
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := HiWiFi HC5962
+ DEVICE_PACKAGES := kmod-usb3 kmod-mt76
+endef
+TARGET_DEVICES += hc5962
+
define Device/mt7621
DTS := MT7621
BLOCKSIZE := 64k